diff mbox series

[bug#57759] * gnu/packages/emacs-xyz.xcm (emacs-expand-region): Update version

Message ID 2cc04d6465846541eb1f019c0731bcbac8087326.1663021613.git.trev@trevdev.ca
State Accepted
Headers show
Series [bug#57759] * gnu/packages/emacs-xyz.xcm (emacs-expand-region): Update version | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Trevor Richards Sept. 12, 2022, 10:25 p.m. UTC
Expand region has continued to evolve outside of tagged releases.
The current git version has patches and helper functions that the
last point release does not.

---
 gnu/packages/emacs-xyz.scm | 12 +++++++-----
 1 file changed, 7 insertions(+), 5 deletions(-)

Comments

Nicolas Goaziou Sept. 13, 2022, 12:49 p.m. UTC | #1
Hello,

Trevor Richards <trev@trevdev.ca> writes:

> Expand region has continued to evolve outside of tagged releases.
> The current git version has patches and helper functions that the
> last point release does not.

I normalized the commit message and applied your patch. Thank you.

Regards,
diff mbox series

Patch

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 19be038746..7c94aed02d 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -5045,18 +5045,20 @@  (define-public emacs-es-mode
     (license license:gpl3+)))
 
 (define-public emacs-expand-region
-  (package
+  (let ((commit "c5c4362741deebb0985a8a29f9b8b0e25160764a")
+        (revision "1"))
+    (package
     (name "emacs-expand-region")
-    (version "0.11.0")
+    (version (git-version "0.11.0" revision commit))
     (source
      (origin
        (method git-fetch)
        (uri (git-reference
              (url "https://github.com/magnars/expand-region.el")
-             (commit version)))
+             (commit commit)))
        (file-name (git-file-name name version))
        (sha256
-        (base32 "0h40dhc3kn8fq86xnwi5lz7ql8my8737y7wkqr897p15y90swr35"))))
+        (base32 "17h58v5mnggbrwrp61cwkqx8hzazkdqyz9p6s1hl9g2hys7zkb00"))))
     (build-system emacs-build-system)
     (home-page "https://github.com/magnars/expand-region.el")
     (synopsis "Increase selected region by semantic units")
@@ -5064,7 +5066,7 @@  (define-public emacs-expand-region
      "Expand region increases the selected region by semantic units.  Just
 keep pressing the key until it selects what you want.  There's also
 @code{er/contract-region} if you expand too far.")
-    (license license:gpl3+)))
+    (license license:gpl3+))))
 
 (define-public emacs-explain-pause-mode
   (let ((commit "2356c8c3639cbeeb9751744dbe737267849b4b51")