[bug#70252,v4,2/5] gnu: %opencl-sdk-version: Update to 2024.10.24.
Commit Message
This updates opencl-headers, opencl-clhpp and opencl-icd-loader.
* gnu/packages/opencl.scm (opencl-headers)[source]: Update hash.
[home-page]: Update URL.
(opencl-clhpp)[source]: Update hash.
(opencl-icd-loader)[source]: Update hash. Update origin URI to fix lint.
Change-Id: I674fc8aa79d1d98bac7ff66ba3a0e0fcb9b243cb
---
v4: Updated to latest version
gnu/packages/opencl.scm | 12 ++++++------
1 file changed, 6 insertions(+), 6 deletions(-)
@@ -58,7 +58,7 @@ (define-module (gnu packages opencl)
;; together (lockstep) and must be updated together. The following variable
;; facilitates that.
-(define %opencl-sdk-version "2023.02.06")
+(define %opencl-sdk-version "2024.10.24")
(define-public opencl-headers
(package
@@ -72,13 +72,13 @@ (define-public opencl-headers
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "1jxpx15gwxc6i7vp64xlzcxf57nl0qnaiip6jyr0j7iji47dm404"))))
+ (base32 "0c3s6g8b3ggfr36cl27axdf3kn79kj6cb880jizcf6q89nw6nf98"))))
(build-system cmake-build-system)
(arguments `(#:tests? #f)) ; Not enabled during build.
(synopsis "The Khronos OpenCL headers")
(description
"This package provides the C headers by Khronos for OpenCL programming.")
- (home-page "https://www.khronos.org/registry/OpenCL/")
+ (home-page "https://registry.khronos.org/OpenCL/")
(license license:asl2.0)))
(define (make-opencl-headers major-version subversion)
@@ -112,7 +112,7 @@ (define-public opencl-clhpp
(url "https://github.com/KhronosGroup/OpenCL-CLHPP")
(commit (string-append "v" version))))
(sha256
- (base32 "1m3v5apjv3qagym32xqg38pq6i8j5d8svz11clsx408nrlyngrj0"))
+ (base32 "1s9z30p80qc1dgp04wvc6szgcs4r167m3nk9622d2bbaaalgd5vg"))
(file-name (git-file-name name version))))
(native-inputs
`(("python" ,python-wrapper)))
@@ -137,12 +137,12 @@ (define-public opencl-icd-loader
(source (origin
(method git-fetch)
(uri (git-reference
- (url "https://github.com/KhronosGroup/OpenCL-ICD-Loader.git")
+ (url "https://github.com/KhronosGroup/OpenCL-ICD-Loader")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
(base32
- "1cmbcm6bz6kfvr0dy9hzf2vgfwcz8gbm8rxspqqpva6z74dz0qxr"))))
+ "0rnyx83iwisxfj818dzf016fmi62kk1hrlfav0b8a1pjfbzmvr03"))))
(build-system cmake-build-system)
(arguments `(#:tests? #f)) ; Tests need stub loader setup.
(native-search-paths