[bug#76841] gnu: icu4c: Fix uri procedure.

Message ID 2c3b35978dc9a06fac074829c2ec79c0509fdf46.1741378663.git.code@greghogan.com
State New
Headers
Series [bug#76841] gnu: icu4c: Fix uri procedure. |

Commit Message

Greg Hogan March 7, 2025, 8:22 p.m. UTC
  This is a small fix for #76750. No rebuilds.

* gnu/packages/icu4c.scm (icu4?-uri, icu4c-uri, icu4j-uri):
Revert to distinct release file suffixes.

Change-Id: Icd1fd03c7147c3ee77111bb815294f654053c203
---
 gnu/packages/icu4c.scm | 8 ++++----
 1 file changed, 4 insertions(+), 4 deletions(-)


base-commit: c8bde3c6725be4eb0743a153a3cf8de453d9e448
  

Comments

Ian Eure March 7, 2025, 8:32 p.m. UTC | #1
Hi Greg,

I just pushed #76841, which duplicates this fix.
  
Greg Hogan March 7, 2025, 8:38 p.m. UTC | #2
On Fri, Mar 7, 2025 at 3:23 PM GNU bug Tracking System
<help-debbugs@gnu.org> wrote:
>
> Thank you for filing a new bug report with debbugs.gnu.org.
>
> This is an automatically generated reply to let you know your message
> has been received.
>
> Your message is being forwarded to the package maintainers and other
> interested parties for their attention; they will reply in due course.
>
> Your message has been sent to the package maintainer(s):
>  guix-patches@gnu.org
>
> If you wish to submit further information on this problem, please
> send it to 76841@debbugs.gnu.org.
>
> Please do not send mail to help-debbugs@gnu.org unless you wish
> to report a problem with the Bug-tracking system.
>
> --
> 76841: https://debbugs.gnu.org/cgi/bugreport.cgi?bug=76841
> GNU Bug Tracking System
> Contact help-debbugs@gnu.org with problems

Fixed by 57171c3243eb30f87a0583e3f554c3cc6c3dd2d0
  
Greg Hogan March 7, 2025, 9:36 p.m. UTC | #3
On Fri, Mar 7, 2025 at 3:32 PM Ian Eure <ian@retrospec.tv> wrote:
>
> Hi Greg,
>
> I just pushed #76841, which duplicates this fix.

I saw it. Thanks!
  

Patch

diff --git a/gnu/packages/icu4c.scm b/gnu/packages/icu4c.scm
index 5209f2f19b1..89546751bd1 100644
--- a/gnu/packages/icu4c.scm
+++ b/gnu/packages/icu4c.scm
@@ -43,19 +43,19 @@  (define-module (gnu packages icu4c)
   #:use-module (guix build-system ant)
   #:use-module (guix build-system gnu))
 
-(define (icu4?-uri variant version)
+(define (icu4?-uri variant suffix version)
   (string-append
    "https://github.com/unicode-org/icu/releases/download/release-"
    (string-map (lambda (x) (if (char=? x #\.) #\- x)) version)
    "/icu4" variant "-"
    (string-map (lambda (x) (if (char=? x #\.) #\_ x)) version)
-   "-src.tgz"))
+   suffix))
 
 (define (icu4c-uri version)
-  (icu4?-uri "c" version))
+  (icu4?-uri "c" "-src.tgz" version))
 
 (define (icu4j-uri version)
-  (icu4?-uri "j" version))
+  (icu4?-uri "j" ".tgz" version))
 
 (define-public icu4c
   (package