diff mbox series

[bug#74290,v3,26/51] DRAFT gnu: bootstrap: Add support for x86_64-gnu, aka the 64bit Hurd.

Message ID 2c35be492f8b105d92a940e3647cc162716f1650.1731999203.git.janneke@gnu.org
State New
Headers show
Series Add support for x86_64-gnu, aka the 64bit Hurd. | expand

Commit Message

Janneke Nieuwenhuizen Nov. 19, 2024, 6:54 a.m. UTC
XXX TODO:

   v Boot a 64bit hurd, and
   v Guix shell --bootstrap -D -e '(@@ (gnu packages commencement) gnu-make-boot0)'
   v Guix build -e '(@@ (gnu packages commencement) gnu-make-boot0)'
   o Guix build hello,
   o Guix shell --bootstrap -D guix,
   o Push the commit below,
   o Re-check the bootstrap-tarballs build/hash,
   o Update this commit message with new commit hash,
   o Push it with remainder of hurd-team branch,
   o Update blog post draft,
   o Release blog post!

On commit:
    610e996dcc82ab7819e9c19d81fdc78b7a9c822c
    gnu: make-bootstrap: Update gcc-static to gcc-14, for the 64bit Hurd.

Run:
    ./pre-inst-env guix build --target=x86_64-gnu bootstrap-tarballs

Producing:
    /gnu/store/7n1vcnzgad4cppzcmd7vnadsggrfm9as-bootstrap-tarballs-0/

With guix hash -r:
    0m66rvp5728c12xab5042gd4v0l1df0821l68brscrc5qr08imsj

* gnu/packages/bootstrap.scm (%bootstrap-executables): Add entries for
x86_64-gnu.
(%bootstrap-guile-hash, %bootstrap-coreutils&co, %bootstrap-binutils,
%bootstrap-glibc, %bootstrap-gcc): Add entry for x86_64-gnu.
* guix/packages.scm (%supported-systems, %hurd-systems): Add x86_64-gnu.
(%cuirass-supported-systems): Remove x86_64-gnu.
* guix/utils.scm (target-64bit?): Add x86_64-gnu.
* m4/guix.m4: Add x86_64-gnu as a supported system.
* doc/guix.texi (GNU Distribution): Add x86_64-gnu.

Change-Id: I828159aedb3f66caba98e935083cc3682429f219
---
 doc/guix.texi              |  9 ++++++++-
 gnu/packages/bootstrap.scm | 34 ++++++++++++++++++++++++++++++++++
 guix/packages.scm          |  8 +++++---
 m4/guix.m4                 | 12 +++++++++---
 4 files changed, 56 insertions(+), 7 deletions(-)
diff mbox series

Patch

diff --git a/doc/guix.texi b/doc/guix.texi
index ba4bd2cc79..ce00811b49 100644
--- a/doc/guix.texi
+++ b/doc/guix.texi
@@ -36,7 +36,7 @@ 
 Copyright @copyright{} 2016, 2017, 2018, 2019, 2020, 2021, 2022, 2023 Efraim Flashner@*
 Copyright @copyright{} 2016 John Darrington@*
 Copyright @copyright{} 2016, 2017 Nikita Gillmann@*
-Copyright @copyright{} 2016, 2017, 2018, 2019, 2020, 2021, 2022, 2023 Jan Nieuwenhuizen@*
+Copyright @copyright{} 2016, 2017, 2018, 2019, 2020, 2021, 2022, 2023, 2024 Janneke Nieuwenhuizen@*
 Copyright @copyright{} 2016, 2017, 2018, 2019, 2020, 2021 Julien Lepiller@*
 Copyright @copyright{} 2016 Alex ter Weele@*
 Copyright @copyright{} 2016, 2017, 2018, 2019, 2020, 2021 Christopher Baines@*
@@ -639,6 +639,13 @@  GNU Distribution
 (@pxref{transparent-emulation-qemu, @code{hurd-vm-service-type}}).
 @xref{Contributing}, on how to help!
 
+@item x86_64-gnu
+@uref{https://hurd.gnu.org, GNU/Hurd} on the @code{x86_64} Intel/AMD
+64-bit architecture.
+
+This configuration is even more experimental and under heavy upstream
+development.
+
 @item mips64el-linux (unsupported)
 little-endian 64-bit MIPS processors, specifically the Loongson series,
 n32 ABI, and Linux-Libre kernel.  This configuration is no longer fully
diff --git a/gnu/packages/bootstrap.scm b/gnu/packages/bootstrap.scm
index 27798fe278..301ee3ca12 100644
--- a/gnu/packages/bootstrap.scm
+++ b/gnu/packages/bootstrap.scm
@@ -125,6 +125,15 @@  (define %bootstrap-executables
       ,(base32 "0nq2c1zb3wv5bf7kd83sziaashydazrn7xgq6kijlk0zj2syzc2m"))
      ("xz"
       ,(base32 "033rhpk6zrpxpd6ffjyg5y2zwq9x9cnq0zljb7k8jlncbalsayq5")))
+    ("x86_64-gnu"
+     ("bash"
+      ,(base32 "0zrcb59s6zm53p74yk0kw8kya5nndcscj4cqvz99fppcblq6c83g"))
+     ("mkdir"
+      ,(base32 "1lbfl66nyvrc8n2ngd9y2gpsm31p4hkn8k6viln0gvd434pf9hnl"))
+     ("tar"
+      ,(base32 "005d5xpnhiyyy2p0widygc65hnrvqd1ryc8ja2q5vpm5ranvbayr"))
+     ("xz"
+      ,(base32 "1qbqxjqm3jsi0av40s62n1nskc98lwl7r12phlw4ca6c1zrlij12")))
     ("mips64el-linux"
      ("bash"
       ,(base32 "1aw046dhda240k9pb9iaj5aqkm23gkvxa9j82n4k7fk87nbrixw6"))
@@ -165,6 +174,7 @@  (define (bootstrap-executable-file-name system program)
   (match system
     ("powerpc64le-linux" (string-append system "/20210106/" program))
     ("i586-gnu" (string-append system "/20200326/" program))
+    ("x86_64-gnu" (string-append system "/20241118/" program))
     ("powerpc-linux" (string-append system "/20200923/bin/" program))
     ("riscv64-linux" (string-append system "/20210725/bin/" program))
     (_ (string-append system "/" program
@@ -366,6 +376,8 @@  (define (bootstrap-guile-url-path system)
                     "/20150101/guile-2.0.11.tar.xz")
                    ("i586-gnu"
                     "/20200326/guile-static-stripped-2.0.14-i586-pc-gnu.tar.xz")
+                   ("x86_64-gnu"
+                    "/20241118/guile-static-stripped-3.0.9-x86_64-pc-gnu.tar.xz")
                    ("powerpc64le-linux"
                     "/20210106/guile-static-stripped-2.0.14-powerpc64le-linux-gnu.tar.xz")
                    ("riscv64-linux"
@@ -390,6 +402,8 @@  (define (bootstrap-guile-hash system)
      (base32 "1giy2aprjmn5fp9c4s9r125fljw4wv6ixy5739i5bffw4jgr0f9r"))
     ("i586-gnu"
      (base32 "0wgqpsmvg25rnqn49ap7kwd2qxccd8dr4lllzp7i3rjvgav27vac"))
+    ("x86_64-gnu"
+     (base32 "1ymp3lck1l5fybsa542ny2fdkfydfcfvqbgr3qh03yvq4fwfn6mc"))
     ("powerpc-linux"
      (base32 "1by2p7s27fbyjzfkcw8h65h4kkqh7d23kv4sgg5jppjn2qx7swq4"))
     ("riscv64-linux"
@@ -599,6 +613,8 @@  (define %bootstrap-coreutils&co
                                              "/20210106/static-binaries-0-powerpc64le-linux-gnu.tar.xz")
                                             ("i586-gnu"
                                              "/20200326/static-binaries-0-i586-pc-gnu.tar.xz")
+                                            ("x86_64-gnu"
+                                             "/20241118/static-binaries-0-x86_64-pc-gnu.tar.xz")
                                             ("powerpc-linux"
                                              "/20200923/static-binaries.tar.xz")
                                             ("riscv64-linux"
@@ -626,6 +642,9 @@  (define %bootstrap-coreutils&co
                               ("i586-gnu"
                                (base32
                                 "17kllqnf3fg79gzy9ansgi801c46yh9c23h4d923plvb0nfm1cfn"))
+                              ("x86_64-gnu"
+                               (base32
+                                "0g5rn94a2kd6g9ggf5m59hypawkwm7r07wwm5730s1mi9w62p248"))
                               ("powerpc-linux"
                                (base32
                                 "0kspxy0yczan2vlih6aa9hailr2inz000fqa0gn5x9d1fxxa5y8m"))
@@ -682,6 +701,8 @@  (define %bootstrap-binutils
                                              "/20210106/binutils-static-stripped-2.34-powerpc64le-linux-gnu.tar.xz")
                                             ("i586-gnu"
                                              "/20200326/binutils-static-stripped-2.34-i586-pc-gnu.tar.xz")
+                                            ("x86_64-gnu"
+                                             "/20241118/binutils-static-stripped-2.41-x86_64-pc-gnu.tar.xz")
                                             ("powerpc-linux"
                                              "/20200923/binutils-2.35.1.tar.xz")
                                             ("riscv64-linux"
@@ -712,6 +733,9 @@  (define %bootstrap-binutils
                               ("i586-gnu"
                                (base32
                                 "11kykv1kmqc5wln57rs4klaqa13hm952smkc57qcsyss21kfjprs"))
+                              ("x86_64-gnu"
+                               (base32
+                                "1zia5fpap35dcpfmmfy6i4p8l3h0d7lzk9bg8apv7vwgw4l1rv9z"))
                               ("powerpc-linux"
                                (base32
                                 "0asbg1c4avkrvh057mx0942xwddd136jni382zqsxzn79ls42yq8"))
@@ -772,6 +796,8 @@  (define %bootstrap-glibc
                                        "/20210106/glibc-stripped-2.31-powerpc64le-linux-gnu.tar.xz")
                                       ("i586-gnu"
                                        "/20240816/glibc-stripped-2.39-i586-pc-gnu.tar.xz")
+                                      ("x86_64-gnu"
+                                       "/20241118/glibc-stripped-2.39-x86_64-pc-gnu.tar.xz")
                                       ("powerpc-linux"
                                        "/20200923/glibc-2.32.tar.xz")
                                       ("riscv64-linux"
@@ -802,6 +828,9 @@  (define %bootstrap-glibc
                         ("i586-gnu"
                          (base32
                           "0x2x6w611k6v9qdabacawamw2475p04hm3s0q95xcg063wjq4ig2"))
+                        ("x86_64-gnu"
+                         (base32
+                          "0d21cy22bhvf11gc859s8ig7gc680ish8mv5xy2l8vrnc12k3q68"))
                         ("powerpc-linux"
                          (base32
                           "0smmssyjrlk5cvx49586smmk81gkwff0i6r91n4rir4jm6ba25sb"))
@@ -878,6 +907,8 @@  (define %bootstrap-gcc
                                         "/20210106/gcc-stripped-5.5.0-powerpc64le-linux-gnu.tar.xz")
                                        ("i586-gnu"
                                         "/20200326/gcc-stripped-5.5.0-i586-pc-gnu.tar.xz")
+                                       ("x86_64-gnu"
+                                        "/20241118/gcc-stripped-14.2.0-x86_64-pc-gnu.tar.xz")
                                        ("powerpc-linux"
                                         "/20200923/gcc-5.5.0.tar.xz")
                                        ("riscv64-linux"
@@ -908,6 +939,9 @@  (define %bootstrap-gcc
                          ("i586-gnu"
                           (base32
                            "1j2zc58wzil71a34h7c70sd68dmqvcscrw3rmn2whq79vd70zvv5"))
+                         ("x86_64-gnu"
+                          (base32
+                           "1di5zbnwnkw679fnhih10c4q8rg2qgqzs424c3dg91sd9l0y0a4j"))
                          ("powerpc-linux"
                           (base32
                            "1p7df3yixhm87dw5sccc6yn1i9db1r9hnmsg87wq5xi4rfmirq7w"))
diff --git a/guix/packages.scm b/guix/packages.scm
index f373136d22..403217d711 100644
--- a/guix/packages.scm
+++ b/guix/packages.scm
@@ -10,6 +10,7 @@ 
 ;;; Copyright © 2022 Maxime Devos <maximedevos@telenet.be>
 ;;; Copyright © 2022 jgart <jgart@dismail.de>
 ;;; Copyright © 2023 Simon Tournier <zimon.toutoune@gmail.com>
+;;; Copyright © 2024 Janneke Nieuwenhuizen <janneke@gnu.org>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -419,7 +420,7 @@  (define %32bit-supported-systems
 (define %64bit-supported-systems
   ;; This is the list of 64-bit system types that are supported.
   '("x86_64-linux" "mips64el-linux" "aarch64-linux" "powerpc64le-linux"
-    "riscv64-linux"))
+    "riscv64-linux" "x86_64-gnu"))
 
 (define %supported-systems
   ;; This is the list of system types that are supported.  By default, we
@@ -428,14 +429,15 @@  (define %supported-systems
 
 (define %hurd-systems
   ;; The GNU/Hurd systems for which support is being developed.
-  '("i586-gnu"))
+  '("i586-gnu" "x86_64-gnu"))
 
 (define %cuirass-supported-systems
   ;; This is the list of system types for which build machines are available.
   ;;
   ;; XXX: MIPS is unavailable in CI:
   ;; <https://lists.gnu.org/archive/html/guix-devel/2017-03/msg00790.html>.
-  (fold delete %supported-systems '("mips64el-linux" "powerpc-linux" "riscv64-linux")))
+  (fold delete %supported-systems '("mips64el-linux" "powerpc-linux"
+                                    "riscv64-linux" "x86_64-gnu")))
 
 (define (maybe-add-input-labels inputs)
   "Add labels to INPUTS unless it already has them."
diff --git a/m4/guix.m4 b/m4/guix.m4
index b93daba5c3..8c2757a8b7 100644
--- a/m4/guix.m4
+++ b/m4/guix.m4
@@ -3,6 +3,7 @@  dnl Copyright © 2012, 2013, 2014, 2015, 2016, 2018, 2019, 2020, 2021 Ludovic Co
 dnl Copyright © 2014 Mark H Weaver <mhw@netris.org>
 dnl Copyright © 2017, 2020, 2021, 2023 Efraim Flashner <efraim@flashner.co.il>
 dnl Copyright © 2021 Chris Marusich <cmmarusich@gmail.com>
+dnl Copyright © 2024 Janneke Nieuwenhuizen <janneke@gnu.org>
 dnl
 dnl This file is part of GNU Guix.
 dnl
@@ -61,8 +62,13 @@  AC_DEFUN([GUIX_SYSTEM_TYPE], [
        linux-musl*)
 	  guix_system="$machine_name-linux";;
        gnu*)
-          # Always use i586 for GNU/Hurd.
-          guix_system="i586-gnu";;
+          case "$machine_name" in
+            i386|i486|i586|i686)
+              # Always use i586 for 32bit GNU/Hurd.
+              guix_system="i586-gnu";;
+            *)
+	      guix_system="$machine_name-gnu";;
+          esac;;
        *)
 	  # Strip the version number from names such as `gnu0.3',
 	  # `darwin10.2.0', etc.
@@ -91,7 +97,7 @@  courageous and port the GNU System distribution to it (see
   # Currently only Linux-based systems are supported, and only on some
   # platforms.
   case "$guix_system" in
-    x86_64-linux|i686-linux|armhf-linux|aarch64-linux|powerpc64le-linux|riscv64-linux|i586-gnu)
+    x86_64-linux|i686-linux|armhf-linux|aarch64-linux|powerpc64le-linux|riscv64-linux|i586-gnu|x86_64-gnu)
       ;;
     mips64el-linux|powerpc-linux)
       AC_MSG_WARN([building Guix on `$guix_system', which is not supported])