diff mbox series

[bug#73021] gnu: Add gnudos.

Message ID 2c135676920165e95a30a67a9aad25b63b4445b7.1725429267.git.atai@atai.org
State New
Headers show
Series [bug#73021] gnu: Add gnudos. | expand

Commit Message

Andy Tai Sept. 4, 2024, 5:54 a.m. UTC
* gnu/packages/mc.scm (gnudos): New variable.

Change-Id: I03a101be81bba3e4fdf8e11a7b4a799b92f86ad0
---
 gnu/packages/mc.scm | 32 ++++++++++++++++++++++++++++++++
 1 file changed, 32 insertions(+)


base-commit: 7fa9df431e9423e2b79c8c520de1d0ef7aed910d
prerequisite-patch-id: a15c31b7d62dad1884467d4668ea9e851a61603e
diff mbox series

Patch

diff --git a/gnu/packages/mc.scm b/gnu/packages/mc.scm
index dc909ed7e1..15eb0e5d8d 100644
--- a/gnu/packages/mc.scm
+++ b/gnu/packages/mc.scm
@@ -120,3 +120,35 @@  (define-public mc
 FTP or FISH.  It also includes a powerful text editor for opening text
 files.")
     (license gpl3+)))
+
+
+(define-public gnudos
+  (package
+    (name "gnudos")
+    (version "2.0")
+    (source
+     (origin
+      (method url-fetch)
+             (uri (string-append "mirror://gnu/gnudos/gnudos-"
+                                 version ".tar.gz"))
+      (sha256
+       (base32 "06n4n6j7w6f54akmqqmsrbxv5rj6xairc6yskm33ag2ar7w8hz48"))))
+    (build-system gnu-build-system)
+    (inputs (list ncurses))
+    (home-page "https://www.gnu.org/software/gnudos/")
+    (synopsis "DOS-like file manager and text editor on the GNU system")
+    (description
+     "GnuDOS is a library designed to help new users of the GNU system, who are
+coming from a DOS background, fit into the picture and start using the GNU
+system with ease. It also addresses the console programmers of such programs
+that have the look and feel of old DOS system. The library is composed of core
+utilities and software applications:
+@itemize
+@item The core library (corelib) contains four utilities: Kbd (for keyboard
+handling), UKbd (with Unicode support), Screen (for screen drawing),
+and Dialogs (for dialog boxes/window drawing).
+
+@item The software applications are: Prime (console file manager), and Mino
+(console text editor).
+@end itemize")
+    (license gpl2+)))