diff mbox series

[bug#65226] gnu: scsh: Fix version number and use gexps.

Message ID 2ba7955e538aada24450172a8f05d3b854e6a76d.1691753983.git.whatson@tailcall.au
State New
Headers show
Series [bug#65226] gnu: scsh: Fix version number and use gexps. | expand

Commit Message

Andrew Whatson Aug. 11, 2023, 11:39 a.m. UTC
* gnu/packages/shells.scm (scsh)[version] Use latest upstream commit.
Use git-version.  Correct base version number to 0.7.
[arguments]: Use gexps and remove trailing #t in phases.
---
 gnu/packages/shells.scm | 30 +++++++++++++++---------------
 1 file changed, 15 insertions(+), 15 deletions(-)


base-commit: ad4520b92662e42d7d0b1e648b2068300dbb95c8
diff mbox series

Patch

diff --git a/gnu/packages/shells.scm b/gnu/packages/shells.scm
index aef22efd01..ca0f4c9ee0 100644
--- a/gnu/packages/shells.scm
+++ b/gnu/packages/shells.scm
@@ -602,11 +602,11 @@  (define-public xonsh
     (license license:bsd-2)))
 
 (define-public scsh
-  (let ((commit "114432435e4eadd54334df6b37fcae505079b49f")
-        (revision "1"))
+  (let ((commit "4acf6e4ed7b65b46186ef0c9c2a1e10bef8dc052")
+        (revision "0"))
     (package
       (name "scsh")
-      (version (string-append "0.0.0-" revision "." (string-take commit 7)))
+      (version (git-version "0.7" revision commit))
       (source
        (origin
          (method git-fetch)
@@ -616,22 +616,22 @@  (define-public scsh
          (file-name (string-append name "-" version "-checkout"))
          (sha256
           (base32
-           "1ghk08akiz7hff1pndi8rmgamgcrn2mv9asbss9l79d3c2iaav3q"))
+           "1czrp808v5gs0ci5lmkp3wr3gfkrb3vd5b2iw2hz1bpqgaf6bxpv"))
          (patches (search-patches "scsh-nonstring-search-path.patch"))))
       (build-system gnu-build-system)
       (arguments
-       `(#:test-target "test"
-         #:phases
-         (modify-phases %standard-phases
-           (add-before 'configure 'replace-rx
-             (lambda* (#:key inputs #:allow-other-keys)
-               (let* ((rx (assoc-ref inputs "scheme48-rx"))
-                      (rxpath (string-append rx "/share/scheme48-"
-                                             ,(package-version scheme48)
+       (list
+        #:test-target "test"
+        #:phases
+        #~(modify-phases %standard-phases
+            (add-before 'configure 'replace-rx
+              (lambda _
+                (let ((rxpath (string-append #$scheme48-rx
+                                             "/share/scheme48-"
+                                             #$(package-version scheme48)
                                              "/rx")))
-                 (delete-file-recursively "rx")
-                 (symlink rxpath "rx"))
-               #t)))))
+                  (delete-file-recursively "rx")
+                  (symlink rxpath "rx")))))))
       (inputs
        (list scheme48 scheme48-rx))
       (native-inputs