diff mbox series

[bug#72835,qt-team,v2,33/74] gnu: Add python-setuptools-scm-next.

Message ID 2b1f9a094a5c53e70bc67d6d8dd3ccb1da421a6b.1726567073.git.zhengjunjie@iscas.ac.cn
State New
Headers show
Series update qt{5,6}. | expand

Commit Message

Z572 Sept. 18, 2024, 1:43 a.m. UTC
* gnu/packages/python-build.scm (python-setuptools-scm-next): New variable.

Change-Id: Ic6b95ed437f95c25c165de3d51732154e2bd954a
---
 gnu/packages/python-build.scm | 32 ++++++++++++++++++++++++++++++++
 1 file changed, 32 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/python-build.scm b/gnu/packages/python-build.scm
index 5b46272bde..47c9c5a9ff 100644
--- a/gnu/packages/python-build.scm
+++ b/gnu/packages/python-build.scm
@@ -11,6 +11,7 @@ 
 ;;; Copyright © 2022 Garek Dyszel <garekdyszel@disroot.org>
 ;;; Copyright © 2022 Greg Hogan <code@greghogan.com>
 ;;; Copyright © 2024 David Elsing <david.elsing@posteo.net>
+;;; Copyright © 2024 Zheng Junjie <873216071@qq.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -677,6 +678,37 @@  (define-public python-setuptools-scm
 them as the version argument or in a SCM managed file.")
     (license license:expat)))
 
+(define-public python-setuptools-scm-next
+  (package
+    (inherit python-setuptools-scm)
+    (name "python-setuptools-scm")
+    (version "8.1.0")
+    (source (origin
+              (method url-fetch)
+              (uri (pypi-uri "setuptools_scm" version))
+              (sha256
+               (base32 "19y84rzqwb2rd88bjrlafrhfail2bnk6apaig8xskjviayva3pj2"))))
+    (build-system pyproject-build-system)
+    (arguments (list
+                ;; pyproject-build-system will error handle forms such as
+                ;; "module:object", so we set it.
+                #:build-backend "setuptools.build_meta"
+                #:phases
+                #~(modify-phases %standard-phases
+                    (add-before 'build 'setenv
+                      (lambda _
+                        ;; pyproject-build-system ignore backend-path,
+                        ;; and __import__ ignore GUIX_PYTHONPATH, so set
+                        ;; PYTHONPATH.
+                        (setenv "PYTHONPATH"
+                                (string-append
+                                 (getcwd)
+                                 ":"
+                                 (getcwd) "/src:"
+                                 (getenv "GUIX_PYTHONPATH"))))))
+                #:tests? #f))    ;avoid extra dependencies such as pytest
+    (native-inputs (list python-setuptools))))
+
 (define-public python-editables
   (package
     (name "python-editables")