diff mbox series

[bug#69277,v2,1/2] gnu: nicotine+: Update to 3.3.0.

Message ID 2abfd2daf4291e16ef019c0a2d727bee9b9b28a2.1708366901.git.juli@incana.org
State New
Headers show
Series [bug#69277,v2,1/2] gnu: nicotine+: Update to 3.3.0. | expand

Commit Message

Juliana Sims Feb. 19, 2024, 6:21 p.m. UTC
Hello,

I forgot to use gtk4 as the latest release of nicotine+ supports it. This patch
series is identical to the previous one except that it uses gtk instead of gtk+.

Thanks,
Juli

* gnu/packages/nicotine.scm (nicotine+): Update to 3.3.0.
---
 gnu/packages/nicotine.scm | 8 ++++----
 1 file changed, 4 insertions(+), 4 deletions(-)


base-commit: 7d6550eec7fe98517a2096d55760a4d5be3ad8ef
diff mbox series

Patch

diff --git a/gnu/packages/nicotine.scm b/gnu/packages/nicotine.scm
index 08232c2756..909adfd3d0 100644
--- a/gnu/packages/nicotine.scm
+++ b/gnu/packages/nicotine.scm
@@ -34,17 +34,17 @@  (define-module (gnu packages nicotine)
 (define-public nicotine+
   (package
     (name "nicotine+")
-    (version "3.2.1")
+    (version "3.3.0")
     (source (origin
               (method git-fetch)
               (uri (git-reference
                     (url "https://github.com/Nicotine-Plus/nicotine-plus")
                     (commit version)))
               (file-name (git-file-name name version))
-              (sha256 (base32 "1x08z5lvkdl62dkc11vrsackgzsh1vr9vp3vgsgfzjyrvlsybmfw"))
+              (sha256 (base32 "1qzc8k2pkw4sgb4p1qrd9d71j8m5v834v0df5qvdfwgnmsn4dnzj"))
               (modules '((guix build utils)))
               ;; Remove test that relies on network access.
-              (snippet '(delete-file-recursively "test/integration"))))
+              (snippet '(delete-file-recursively "pynicotine/tests/unit/test_version.py"))))
     (build-system python-build-system)
     (arguments
      `(#:imported-modules ((guix build glib-or-gtk-build-system)
@@ -72,7 +72,7 @@  (define-public nicotine+
              (when tests?
                (invoke "xvfb-run" "python" "-m" "unittest")))))))
     (inputs
-     (list bash-minimal gspell gtk+ python-pygobject libappindicator python-pytaglib))
+     (list bash-minimal gspell gtk python-pygobject libappindicator python-pytaglib))
     (native-inputs
      (list gettext-minimal xvfb-run))
     (home-page "https://nicotine-plus.org/")