diff mbox series

[bug#60437] gnu: Add python-elgato-streamdeck.

Message ID 2a939ae3310e4a6973507cd7af4daecc6eeb72cd.1672436745.git.bjc@spork.org
State New
Headers show
Series [bug#60437] gnu: Add python-elgato-streamdeck. | expand

Commit Message

Brian Cully Dec. 30, 2022, 9:45 p.m. UTC
* gnu/packages/python-xyz.scm: (python-elgato-streamdeck) New variable.
---
 gnu/packages/python-xyz.scm | 29 +++++++++++++++++++++++++++++
 1 file changed, 29 insertions(+)

Comments

Brian Cully April 6, 2023, 6:56 p.m. UTC | #1
Can someone please take a look at this patch? It still applies cleanly
to master.

I've been using this, by way of ‘python-streamdeck-ui’ for many months
now.
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index d2623bc32d..445efe563b 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -27734,6 +27734,35 @@  (define-public python-rnc2rng
 equivalent schemata in the XML-based default RELAX NG syntax.")
     (license license:expat)))
 
+(define-public python-elgato-streamdeck
+  (package
+    (name "python-elgato-streamdeck")
+    (version "0.9.3")
+    (source (origin
+              (method url-fetch)
+              (uri (pypi-uri "streamdeck" version))
+              (sha256
+               (base32
+                "0wgcvz3l3qllwvsadsq6y96wc3p16agzmwwx26v3ir0ns6q5dczm"))))
+    (build-system python-build-system)
+    (arguments
+     (list #:phases #~(modify-phases %standard-phases
+                        (add-after 'unpack 'patch-source
+                          (lambda* (#:key inputs #:allow-other-keys)
+                            (substitute* "src/StreamDeck/Transport/LibUSBHIDAPI.py"
+                              (("libhidapi-libusb.so")
+                               (search-input-file inputs
+                                                  "/lib/libhidapi-libusb.so"))))))))
+    (home-page "https://github.com/abcminiuser/python-elgato-streamdeck")
+    (synopsis "Library to control Elgato StreamDeck devices")
+    (description "Library to control Elgato StreamDeck devices.")
+    (license (license:non-copyleft
+              (string-append
+               "https://github.com/abcminiuser/python-elgato-streamdeck"
+               "/blob/master/LICENSE")))
+    (propagated-inputs (list python-pillow))
+    (inputs (list hidapi))))
+
 (define-public python-pynput
   (package
     (name "python-pynput")