diff mbox series

[bug#59356,3/5] gnu: Add go-github-com-makeworld-the-better-one-gemget.

Message ID 2a800688-110b-c905-2a9e-b882dd772987@disroot.org
State New
Headers show
Series [bug#59356] gnu: Add go-github-com-k0kubun-go-ansi. | expand

Commit Message

Adam Faiz Nov. 18, 2022, 11:51 a.m. UTC
From d2b2741b0b800e1371b53d0f0a72cd69a35838ab Mon Sep 17 00:00:00 2001
From: AwesomeAdam54321 <adam.faiz@disroot.org>
Date: Fri, 18 Nov 2022 09:03:42 +0800
Subject: [PATCH] gnu: Add go-github-com-schollz-progressbar.

* gnu/packages/golang.scm (go-github-com-schollz-progressbar): New variable.
---
  gnu/packages/golang.scm | 35 +++++++++++++++++++++++++++++++++++
  1 file changed, 35 insertions(+)

    (let ((commit "52f3993e8d6d2629f18e7b7383b7f54a3d3f1d1f")
          (revision "0"))
diff mbox series

Patch

diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 71aa2ec972..c988b50574 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -1287,6 +1287,41 @@  (define-public go-github-com-schachmat-ingo
  configuration file.")
      (license license:isc)))

+(define-public go-github-com-schollz-progressbar
+  (package
+    (name "go-github-com-schollz-progressbar")
+    (version "3.12.1")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/schollz/progressbar")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "1xf6vrrvimrhb6hrkcax0ig6f0zy3skiapxjhfqc1n0lmvbxwqyf"))))
+    (build-system go-build-system)
+    (arguments
+     (list #:tests? #f ;TestReaderToBuffer panic: runtime error:
+                       ;invalid memory address or nil pointer 
dereference [recovered]
+           #:import-path "github.com/schollz/progressbar/v3"))
+    (propagated-inputs
+     (list go-golang-org-x-term
+           go-golang-org-x-sys
+           go-github-com-stretchr-testify
+           go-github-com-rivo-uniseg
+           go-github-com-mitchellh-colorstring
+           go-github-com-mattn-go-runewidth
+           go-github-com-mattn-go-isatty
+           go-github-com-k0kubun-go-ansi
+           go-github-com-davecgh-go-spew))
+    (home-page "https://github.com/schollz/progressbar")
+    (synopsis "Basic thread-safe progress bar for Golang applications")
+    (description
+     "schollz-progressbar provides a very simple thread-safe progress 
bar which should work
+on every OS without problems.")
+    (license license:expat)))
+
  (define-public go-github-com-savsgio-gotils