[bug#75503,4/4] gnu: Add partitionmanager.

Message ID 2a037410a7a7df8af91f976bc0002d671791cf7d.1736636962.git.sughosha@disroot.org
State New
Headers
Series gnu: Add partitionmanager. |

Commit Message

Sughosha Jan. 11, 2025, 11:15 p.m. UTC
  * gnu/packages/kde.scm (partitionmanager): New variable.

Change-Id: If8f03f352a580c5b11f3508733710d2eb8c45dae
---
 gnu/packages/kde.scm | 39 +++++++++++++++++++++++++++++++++++++++
 1 file changed, 39 insertions(+)
  

Patch

diff --git a/gnu/packages/kde.scm b/gnu/packages/kde.scm
index a08634bee8..a8471ea935 100644
--- a/gnu/packages/kde.scm
+++ b/gnu/packages/kde.scm
@@ -1339,6 +1339,45 @@  (define-public kpmcore
     (description "Library for managing partitions.")
     (license license:gpl3+)))
 
+(define-public partitionmanager
+  (package
+    (name "partitionmanager")
+    (version "24.05.2")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "mirror://kde/stable/release-service/" version
+                           "/src/partitionmanager-" version ".tar.xz"))
+       (sha256
+        (base32 "01xmwkwv8jrwx2jpg797ar8ac9gbdagrl2v3yzqn62fhwcwjcxy6"))))
+    (build-system qt-build-system)
+    (arguments
+     (list #:qtbase qtbase))
+    (native-inputs
+     (list extra-cmake-modules kdoctools))
+    (inputs
+     (list kconfig
+           kconfigwidgets
+           kcoreaddons
+           kcrash
+           kdbusaddons
+           ki18n
+           kio
+           kjobwidgets
+           kpmcore
+           kwidgetsaddons
+           kwindowsystem
+           kxmlgui
+           polkit-qt6))
+    (home-page "https://apps.kde.org/partitionmanager/")
+    (synopsis "Disk device, partition and file system manager")
+    (description "KDE Partition Manager is a utility to help you manage the
+disks, partitions, and file systems.  It allows you to easily create, copy,
+move, delete, back up, restore, and resize them without losing data.  It
+supports a large number of file systems, including ext2/3/4, btrfs, NTFS,
+FAT16/32, JFS, XFS and more.")
+    (license license:gpl3+)))
+
 (define-public kpublictransport
   (package
     (name "kpublictransport")