diff mbox series

[bug#52803,v2] gnu: Add headsetcontrol.

Message ID 2_c_qvqxrYLkzqE6Wi-swccI8XaI8F5g_J3nkn7XQ0WzTLUezJLbflel0dROLPJGoOHkShwG63WMQBGTiloR9XVKFSALj8cB9LNxtKZzt2M=@pm.me
State Accepted
Headers show
Series [bug#52803,v2] gnu: Add headsetcontrol. | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

John Kehayias Dec. 26, 2021, 4:41 p.m. UTC
Forgot the copyright line, added in this version.

Comments

Nicolas Goaziou Dec. 27, 2021, 9:49 a.m. UTC | #1
Hello,

John Kehayias via Guix-patches via <guix-patches@gnu.org> writes:

> Subject: [PATCH] gnu: Add headsetcontrol.
>
> * gnu/packages/hardware.scm (headsetcontrol): New variable.

Thank you. I pushed it with the changes detailed below.

> +(define-public headsetcontrol
> +  (package
> +    (name "headsetcontrol")
> +    (version "2.6")
> +    (source (origin
> +             (method git-fetch)

I moved `origin' below `source' and adjusted indentation.

> +             (uri (git-reference
> +                   (url "https://github.com/Sapd/HeadsetControl")
> +                   (commit version)))
> +             (file-name (git-file-name name version))
> +             (sha256
> +              (base32
> +               "0a7zimzi71416pmn6z0l1dn1c2x8p702hkd0k6da9rsznff85a88"))))

I moved hash on the same line as `base32'

> +    (build-system cmake-build-system)
> +    (inputs
> +      (list hidapi))
> +    (synopsis "Sidetone and Battery status for USB headsets")
> +    (description
> +      "A tool to control certain aspects of USB-connected headsets on Linux.

I started the description with the name of the package (guix lint
should warn you about this), and removed reference to Linux, since it is
not useful in Guix.

> +Currently, support is provided for adjusting sidetone, getting battery state,
> +controlling LEDs, and setting the inactive time.")
> +    (home-page "https://github.com/Sapd/HeadsetControl")
> +    (license license:gpl3)))

I used gpl3+ as "main.c" includes "or (at your option) any later
version" in its header.

Regards,
John Kehayias Dec. 27, 2021, 3:07 p.m. UTC | #2
Hi Nicolas,

‐‐‐‐‐‐‐ Original Message ‐‐‐‐‐‐‐

On Monday, December 27th, 2021 at 4:49 AM, Nicolas Goaziou wrote:

> Hello,
>
> John Kehayias via Guix-patches via guix-patches@gnu.org writes:
>
> > Subject: [PATCH] gnu: Add headsetcontrol.
> >
> > -   gnu/packages/hardware.scm (headsetcontrol): New variable.
>
> Thank you. I pushed it with the changes detailed below.
>

Thanks! Not sure how I missed that guix lint suggestion (I did run it), will keep a look out for that in case it did miss it for some reason.

John
diff mbox series

Patch

From 6ffd909e7609856111b2164067cac59fbcb2b025 Mon Sep 17 00:00:00 2001
From: John Kehayias <john.kehayias@protonmail.com>
Date: Sun, 26 Dec 2021 11:13:29 -0500
Subject: [PATCH] gnu: Add headsetcontrol.

* gnu/packages/hardware.scm (headsetcontrol): New variable.
---
 gnu/packages/hardware.scm | 25 +++++++++++++++++++++++++
 1 file changed, 25 insertions(+)

diff --git a/gnu/packages/hardware.scm b/gnu/packages/hardware.scm
index ddd0f5acc1..c7ebb9b7f2 100644
--- a/gnu/packages/hardware.scm
+++ b/gnu/packages/hardware.scm
@@ -8,6 +8,7 @@ 
 ;;; Copyright © 2021 Petr Hodina <phodina@protonmail.com>
 ;;; Copyright © 2021 Raghav Gururajan <rg@raghavgururajan.name>
 ;;; Copyright © 2021 Vinicius Monego <monego@posteo.net>
+;;; Copyright © 2021 John Kehayias <john.kehayias@protonmail.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -316,6 +317,30 @@  (define-public h-client
       (home-page "https://savannah.nongnu.org/projects/h-client/")
       (license license:gpl3+))))
 
+(define-public headsetcontrol
+  (package
+    (name "headsetcontrol")
+    (version "2.6")
+    (source (origin
+             (method git-fetch)
+             (uri (git-reference
+                   (url "https://github.com/Sapd/HeadsetControl")
+                   (commit version)))
+             (file-name (git-file-name name version))
+             (sha256
+              (base32
+               "0a7zimzi71416pmn6z0l1dn1c2x8p702hkd0k6da9rsznff85a88"))))
+    (build-system cmake-build-system)
+    (inputs
+      (list hidapi))
+    (synopsis "Sidetone and Battery status for USB headsets")
+    (description
+      "A tool to control certain aspects of USB-connected headsets on Linux.
+Currently, support is provided for adjusting sidetone, getting battery state,
+controlling LEDs, and setting the inactive time.")
+    (home-page "https://github.com/Sapd/HeadsetControl")
+    (license license:gpl3)))
+
 (define-public i7z
   (let ((revision "0")
         (commit "1a41ff13db747e962456ddbb5ccb2b7fc43ca0cb"))
-- 
2.34.1