diff mbox series

[bug#51730,19/21] gnu: Add rust-wl-clipboard-rs-0.4.

Message ID 2UFj5ObV9BKYbYJelqG8tpNRfk2ydikShOoje77XlKyAGsGoiPiiAFRUOl89abm33GcBBeb3SDuj0edL0KDW2LFhblcpI1zjCV2W8jzKB-U=@protonmail.com
State Accepted
Headers show
Series [bug#51730,01/21] gnu: Add rust-argh-shared-0.1. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

phodina Nov. 9, 2021, 9:22 p.m. UTC
* gnu/packages/crates-graphics.scm (rust-wl-clipboard-rs-0.4): New variable.
* gnu/packages/patches/rust-wl-clipboard-rs-newer-wl.patch: New file.
* gnu/local.mk: Add patch.

--
2.33.1

Comments

Nicolas Goaziou Nov. 17, 2021, 5:44 p.m. UTC | #1
Hello,

phodina via Guix-patches via <guix-patches@gnu.org> writes:

> * gnu/packages/crates-graphics.scm (rust-wl-clipboard-rs-0.4): New variable.
> * gnu/packages/patches/rust-wl-clipboard-rs-newer-wl.patch: New file.
> * gnu/local.mk: Add patch.

This patch does not apply on current master + all previous patches.
Also, I don't think it belongs to "crate-graphics.scm" but rather to
"crates-io.scm".

Could you send an updated patch or various patch files as attachment so
I can re-create the patch?

Thanks,

Regards,
diff mbox series

Patch

diff --git a/gnu/local.mk b/gnu/local.mk
index 05258ac054..01a82248f1 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -1760,6 +1760,7 @@  dist_patch_DATA =					\
   %D%/packages/patches/rust-nettle-sys-disable-vendor.patch	 \
   %D%/packages/patches/rust-reproducible-builds.patch		 \
   %D%/packages/patches/rust-openssl-sys-no-vendor.patch	\
+  %D%/packages/patches/rust-wl-clipboard-rs-newer-wl.patch \
   %D%/packages/patches/sbc-fix-build-non-x86.patch		\
   %D%/packages/patches/sbcl-burgled-batteries3-fix-signals.patch\
   %D%/packages/patches/sbcl-clml-fix-types.patch		\
diff --git a/gnu/packages/crates-graphics.scm b/gnu/packages/crates-graphics.scm
index d50056e948..a1ea11416c 100644
--- a/gnu/packages/crates-graphics.scm
+++ b/gnu/packages/crates-graphics.scm
@@ -2402,6 +2402,44 @@  (define-public rust-wayland-client-0.21
        (("rust-byteorder" ,rust-byteorder-1)
         ("rust-tempfile" ,rust-tempfile-3))))))

+(define-public rust-wl-clipboard-rs-0.4
+  (package
+    (name "rust-wl-clipboard-rs")
+    (version "0.4.1")
+    (source
+      (origin
+        (method url-fetch)
+        (uri (crate-uri "wl-clipboard-rs" version))
+        (file-name (string-append name "-" version ".tar.gz"))
+        (patches (search-patches "rust-wl-clipboard-rs-newer-wl.patch"))
+        (sha256
+          (base32 "1252cm67pkrr6ik5ys2cdyfr2zzw6ds7v351i1cmyi94yiv01l13"))))
+    (build-system cargo-build-system)
+    (arguments
+      `(#:skip-build? #t
+        #:cargo-inputs
+        (("rust-derive-new" ,rust-derive-new-0.5)
+         ("rust-derive-more" ,rust-derive-more-0.99)
+         ("rust-exitfailure" ,rust-exitfailure-0.5)
+         ("rust-failure" ,rust-failure-0.1)
+         ("rust-libc" ,rust-libc-0.2)
+         ("rust-log" ,rust-log-0.4)
+         ("rust-mime-guess" ,rust-mime-guess-2)
+         ("rust-nix" ,rust-nix-0.18)
+         ("rust-os-pipe" ,rust-os-pipe-0.9)
+         ("rust-stderrlog" ,rust-stderrlog-0.4)
+         ("rust-structopt" ,rust-structopt-0.3)
+         ("rust-tempfile" ,rust-tempfile-3)
+         ("rust-tree-magic" ,rust-tree-magic-0.2)
+         ("rust-wayland-client" ,rust-wayland-client-0.28)
+         ("rust-wayland-commons" ,rust-wayland-commons-0.28)
+         ("rust-wayland-protocols" ,rust-wayland-protocols-0.28))))
+    (home-page "https://github.com/YaLTeR/wl-clipboard-rs")
+    (synopsis "Access to the Wayland clipboard")
+    (description "This package provides access to the Wayland clipboard
+for terminal and other window-less applications.")
+    (license (list license:expat license:asl2.0))))
+
 (define-public rust-wayland-commons-0.28
   (package
     (name "rust-wayland-commons")
diff --git a/gnu/packages/patches/rust-wl-clipboard-rs-newer-wl.patch b/gnu/packages/patches/rust-wl-clipboard-rs-newer-wl.patch
new file mode 100644
index 0000000000..9fb692e9a6
--- /dev/null
+++ b/gnu/packages/patches/rust-wl-clipboard-rs-newer-wl.patch
@@ -0,0 +1,26 @@ 
+diff --git a/Cargo.toml b/Cargo.toml
+index 7b975e0..313cb63 100644
+--- a/Cargo.toml
++++ b/Cargo.toml.new
+@@ -75,17 +75,17 @@ version = "3"
+ version = "0.2"
+
+ [dependencies.wayland-client]
+-version = "0.27"
++version = "0.28"
+
+ [dependencies.wayland-protocols]
+-version = "0.27"
++version = "0.28"
+ features = ["client", "unstable_protocols"]
+ [dev-dependencies.wayland-protocols]
+-version = "0.27"
++version = "0.28"
+ features = ["server", "unstable_protocols"]
+
+ [dev-dependencies.wayland-server]
+-version = "0.27"
++version = "0.28"
+
+ [features]
+ dlopen = ["native_lib", "wayland-client/dlopen", "wayland-server/dlopen"]