diff mbox series

[bug#57702,1/8] gnu: Add rust-unic-emoji-char-0.9.

Message ID 2FM_77W4h13TjSAPpcyy8a8xVR43mgwJ09tQ9hn6-5iFxXrD6R77GtNPyYntp4T-bx18UhiS7DCf1WdcKIWjDpH2A6wwKPd-YdQEXTU1e48=@protonmail.com
State New
Headers show
Series [bug#57702,1/8] gnu: Add rust-unic-emoji-char-0.9. | expand

Commit Message

VesselWave Sept. 9, 2022, 6:05 p.m. UTC
---
 gnu/packages/crates-io.scm | 23 +++++++++++++++++++++++
 1 file changed, 23 insertions(+)

--
2.37.2

Comments

M Sept. 10, 2022, 12:13 a.m. UTC | #1
On 09-09-2022 20:05, VesselWave via Guix-patches via wrote:
> 
> ---
>   gnu/packages/crates-io.scm | 23 +++++++++++++++++++++++
>   1 file changed, 23 insertions(+)
> 
> diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
> index 02f7bc7d4d..a82515f73e 100644
> --- a/gnu/packages/crates-io.scm
> +++ b/gnu/packages/crates-io.scm
> @@ -69234,6 +69234,29 @@ (define-public rust-unic-common-0.9
>   Internationalization Crates (UNIC) project.")
>       (license (list license:expat license:asl2.0))))
> 
> +(define-public rust-unic-emoji-char-0.9
> +  (package
> +    (name "rust-unic-emoji-char")
> +    (version "0.9.0")
> +    (source (origin
> +              (method url-fetch)
> +              (uri (crate-uri "unic-emoji-char" version))
> +              (file-name (string-append name "-" version ".tar.gz"))
> +              (sha256
> +               (base32
> +                "0ka9fr7s6lv0z43r9xphg9injn35pfxf9g9q18ki0wl9d0g241qb"))))

This contains various binaries (i.e., non-source, I don't mean it in the 
executable sense), see the .rsv files in 
<https://github.com/open-i18n/rust-unic/tree/master/unic/emoji/char/tables>

> // WARNING: Auto-generated by the `unic-gen` crate.
> // WARNING: DO NOT EDIT MANUALLY!


they need to be built from source instead, presumably with this 
`unic-gen`.  To make sure the binaries aren't used, they can be removed 
in the origin, with snippet ('delete-file-recursively' can be useful). 
A post-unpack phase can be useful for regenerating these binaries.

Greetings,
Maxime.
diff mbox series

Patch

diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 02f7bc7d4d..a82515f73e 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -69234,6 +69234,29 @@  (define-public rust-unic-common-0.9
 Internationalization Crates (UNIC) project.")
     (license (list license:expat license:asl2.0))))

+(define-public rust-unic-emoji-char-0.9
+  (package
+    (name "rust-unic-emoji-char")
+    (version "0.9.0")
+    (source (origin
+              (method url-fetch)
+              (uri (crate-uri "unic-emoji-char" version))
+              (file-name (string-append name "-" version ".tar.gz"))
+              (sha256
+               (base32
+                "0ka9fr7s6lv0z43r9xphg9injn35pfxf9g9q18ki0wl9d0g241qb"))))
+    (build-system cargo-build-system)
+    (arguments
+     `(#:skip-build? #t
+       #:cargo-inputs (("rust-unic-property-char" ,rust-unic-char-property-0.9)
+                       ("rust-unic-char-range" ,rust-unic-char-range-0.9)
+                       ("rust-unic-ucd-version" ,rust-unic-ucd-version-0.9))))
+    (home-page "https://github.com/open-i18n/rust-unic/")
+    (synopsis "Emoji character properties for UNIC")
+    (description "This package provides emoji character properties and for
+the Unicode and Internationalization Crates (UNIC) project.")
+    (license (list license:expat license:asl2.0))))
+
 (define-public rust-unic-segment-0.9
   (package
     (name "rust-unic-segment")