diff mbox series

[bug#45449,v2] gnu: Add python-serial.

Message ID 2F4T0FL1OpArIdmKuueSPeyDx6uCe7ox2mc6F0wFR8xTcF4D5uqRruF572ouFHMOQdBJc7jTK0sYVnLWdWTRIpMmU7BMFeQGI6wwf9U9Qjc=@protonmail.com
State New
Headers show
Series [bug#45449,v2] gnu: Add python-serial. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

phodina Nov. 3, 2021, 8:45 a.m. UTC
Hi Mathieu,

here's the reworked patch.

Petr

--8<---------------cut here---------------start------------->8---

* gnu/packages/python-xyz.scm (python-serial): New variable.

--
2.33.1

Comments

Maxim Cournoyer Jan. 16, 2023, 6:08 p.m. UTC | #1
Hi,

phodina <phodina@protonmail.com> writes:

> Hi Mathieu,
>
> here's the reworked patch.
>
> Petr

The package upstream appears to have vanished, and the last pypi release
is from 2019.  Closing this as done.
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 32d6b403d4..35c2bffd47 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -94,6 +94,7 @@ 
 ;;; Copyright © 2020, 2021 Zheng Junjie <873216071@qq.com>
 ;;; Copyright © 2021 Morgan Smith <Morgan.J.Smith@outlook.com>
 ;;; Copyright © 2020 EuAndreh <eu@euandre.org>
+;;; Copyright © 2020 Ryan Desfosses <rdes@protonmail.com>
 ;;; Copyright © 2021 Sharlatan Hellseher <sharlatanus@gmail.com>
 ;;; Copyright © 2021 Ellis Kenyő <me@elken.dev>
 ;;; Copyright © 2021 LibreMiami <packaging-guix@libremiami.org>
@@ -1645,6 +1646,31 @@  (define-public python-semantic-version
 (define-public python2-semantic-version
   (package-with-python2 python-semantic-version))

+(define-public python-serial
+  (package
+  (name "python-serial")
+  (version "0.0.97")
+  (source
+    (origin
+      (method url-fetch)
+      (uri (pypi-uri "serial" version))
+      (sha256
+        (base32
+          "0j7qjif5d9mxbdwcyyhr7fpcvjq7x16ar9n3mk95xgyx4yhm08al"))))
+  (build-system python-build-system)
+  (propagated-inputs
+    `(("python-future" ,python-future)
+      ("python-iso8601" ,python-iso8601)
+      ("python-pyyaml" ,python-pyyaml)))
+  (home-page
+    "https://bitbucket.com/davebelais/serial.git")
+  (synopsis
+    "Framework for serializing/deserializing JSON/YAML/XML")
+  (description
+    "This package provides a framework for serializing/deserializing
+JSON/YAML/XML into python class instances and vice versa")
+  (license license:expat)))
+
 (define-public python-serpent
   (package
     (name "python-serpent")