diff mbox series

[bug#64552] gnu: Add dhex.

Message ID 29a2c5263ac72f950491f627b6055ecb675f0068.1688931860.git.flabbergasted@nofog.net
State New
Headers show
Series [bug#64552] gnu: Add dhex. | expand

Commit Message

flabbergasted July 10, 2023, 9:24 a.m. UTC
* gnu/packages/hexedit.scm (dhex): New variable.
---
 gnu/packages/hexedit.scm | 46 ++++++++++++++++++++++++++++++++++++++++
 1 file changed, 46 insertions(+)


base-commit: f0ca6346a46c605a590bfd77b84e143a8c759a3b

Comments

Maxim Cournoyer Sept. 5, 2023, 2:59 p.m. UTC | #1
Hello,

flabbergasted <flabbergasted@nofog.net> writes:

> * gnu/packages/hexedit.scm (dhex): New variable.
> ---
>  gnu/packages/hexedit.scm | 46 ++++++++++++++++++++++++++++++++++++++++
>  1 file changed, 46 insertions(+)
>
> diff --git a/gnu/packages/hexedit.scm b/gnu/packages/hexedit.scm
> index 79c14a2..002f6d0 100644
> --- a/gnu/packages/hexedit.scm
> +++ b/gnu/packages/hexedit.scm
> @@ -29,6 +29,8 @@ (define-module (gnu packages hexedit)
>    #:use-module (gnu packages ncurses)
>    #:use-module (guix download)
>    #:use-module (guix git-download)
> +  #:use-module (guix gexp)
> +  #:use-module (guix utils)
>    #:use-module (guix build-system gnu))
>  
>  (define-public hexedit
> @@ -69,6 +71,50 @@ (define-public hexedit
>      (home-page "http://rigaux.org/hexedit.html")
>      (license license:gpl2+)))
>  
> +(define-public dhex
> +  (package
> +    (name "dhex")
> +    (version "0.69")
> +    (source (origin
> +              (method url-fetch)
> +              (uri (string-append "https://www.dettus.net/dhex/" name "_"
> +                                  version ".tar.gz"))
> +              (sha256
> +               (base32
> +                "06y4lrp29f2fh303ijk1xhspa1d4x4dm6hnyw3dd8szi3k6hnwsj"))))
> +    (build-system gnu-build-system)
> +    (arguments
> +     (list
> +      #:tests? #f ;no tests provided
> +      #:make-flags
> +      #~(list (string-append "CC=" #$(cc-for-target)))
> +      #:phases
> +      #~(modify-phases %standard-phases
> +          (delete 'configure) ;no configure script
> +          (replace 'install ;multiple issues with provided 'make install'
> +            (lambda _
> +              (let ((bin (string-append #$output "/bin"))
> +                    (man1 (string-append #$output
> +                                         "/share/man/man1"))
> +                    (man5 (string-append #$output
> +                                         "/share/man/man5")))
> +                (mkdir-p bin)
> +                (install-file "dhex" bin)
> +                (mkdir-p man1)
> +                (install-file "dhex.1" man1)
> +                (mkdir-p man5)
> +                (install-file "dhexrc.5" man5)
> +                (install-file "dhex_markers.5" man5)
> +                (install-file "dhex_searchlog.5" man5)))))))

install-file takes care of calling 'mkdir' for you, so you can simplify
the above.

> +    (inputs (list ncurses))
> +    (home-page "https://www.dettus.net/dhex/")
> +    (synopsis "View, edit, and diff files in hexadecimal")
> +    (description
> +     "Dhex is hex editor which includes a diff mode, which can be used to
> +easily and conveniently compare two binary files.  It is based on ncurses
> +and is themeable.")
> +    (license license:gpl2)))

This should be gpl2+, given the text reads:

--8<---------------cut here---------------start------------->8---
This program is free software; you can redistribute it and/or modify
it under the terms of the GNU General Public License as published by
the Free Software Foundation; either version 2 of the License, or
(at your option) any later version.
--8<---------------cut here---------------end--------------->8---

Could you please send a v2 with the above corrections?
flabbergasted Sept. 9, 2023, 10:06 a.m. UTC | #2
Hi Maxim,

thank you for the suggestions! I have updated the patch.
(Apologies if I'm using the bug system incorrectly.)

Kind regards,
 (flabbergasted)
diff mbox series

Patch

diff --git a/gnu/packages/hexedit.scm b/gnu/packages/hexedit.scm
index 79c14a2..002f6d0 100644
--- a/gnu/packages/hexedit.scm
+++ b/gnu/packages/hexedit.scm
@@ -29,6 +29,8 @@  (define-module (gnu packages hexedit)
   #:use-module (gnu packages ncurses)
   #:use-module (guix download)
   #:use-module (guix git-download)
+  #:use-module (guix gexp)
+  #:use-module (guix utils)
   #:use-module (guix build-system gnu))
 
 (define-public hexedit
@@ -69,6 +71,50 @@  (define-public hexedit
     (home-page "http://rigaux.org/hexedit.html")
     (license license:gpl2+)))
 
+(define-public dhex
+  (package
+    (name "dhex")
+    (version "0.69")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append "https://www.dettus.net/dhex/" name "_"
+                                  version ".tar.gz"))
+              (sha256
+               (base32
+                "06y4lrp29f2fh303ijk1xhspa1d4x4dm6hnyw3dd8szi3k6hnwsj"))))
+    (build-system gnu-build-system)
+    (arguments
+     (list
+      #:tests? #f ;no tests provided
+      #:make-flags
+      #~(list (string-append "CC=" #$(cc-for-target)))
+      #:phases
+      #~(modify-phases %standard-phases
+          (delete 'configure) ;no configure script
+          (replace 'install ;multiple issues with provided 'make install'
+            (lambda _
+              (let ((bin (string-append #$output "/bin"))
+                    (man1 (string-append #$output
+                                         "/share/man/man1"))
+                    (man5 (string-append #$output
+                                         "/share/man/man5")))
+                (mkdir-p bin)
+                (install-file "dhex" bin)
+                (mkdir-p man1)
+                (install-file "dhex.1" man1)
+                (mkdir-p man5)
+                (install-file "dhexrc.5" man5)
+                (install-file "dhex_markers.5" man5)
+                (install-file "dhex_searchlog.5" man5)))))))
+    (inputs (list ncurses))
+    (home-page "https://www.dettus.net/dhex/")
+    (synopsis "View, edit, and diff files in hexadecimal")
+    (description
+     "Dhex is hex editor which includes a diff mode, which can be used to
+easily and conveniently compare two binary files.  It is based on ncurses
+and is themeable.")
+    (license license:gpl2)))
+
 (define-public ht
   (package
     (name "ht")