[bug#76510] gnu: Add emacs-notmuch-addr.

Message ID 29a1ac5407a6aae855e15ead21bb51cc54a18ac3.1740336919.git.liam@hpfr.net
State New
Headers
Series [bug#76510] gnu: Add emacs-notmuch-addr. |

Commit Message

Liam Hupfer Feb. 23, 2025, 6:55 p.m. UTC
  * gnu/packages/emacs-xyz.scm (emacs-notmuch-addr): New variable.

Change-Id: I99fffb1d5e442b667d1fbf14bcb532923395cf63
---
 gnu/packages/emacs-xyz.scm | 25 ++++++++++++++++++++++++-
 1 file changed, 24 insertions(+), 1 deletion(-)


base-commit: 6cd8c5849666af658c4b2e3bd4436e1a77691e41
  

Comments

Ian Eure March 1, 2025, 5:15 p.m. UTC | #1
Hi Liam,

Pushed as ca87fed4a8.

Thanks,
  -- Ian
  

Patch

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index e6bc0bba1d..ea50710227 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -147,7 +147,7 @@ 
 ;;; Copyright © 2024 Artyom V. Poptsov <poptsov.artyom@gmail.com>
 ;;; Copyright © 2024 Spencer King <spencer.king@nursiapress.com>
 ;;; Copyright © 2024 emma thompson <bigbookofbug@proton.me>
-;;; Copyright © 2024 Liam Hupfer <liam@hpfr.net>
+;;; Copyright © 2024-2025 Liam Hupfer <liam@hpfr.net>
 ;;; Copyright © 2024 aurtzy <aurtzy@gmail.com>
 ;;; Copyright © 2024 Olivier Rojon <o.rojon@posteo.net>
 ;;; Copyright © 2024 Divya Ranjan Pattanaik <divya@subvertising.org>
@@ -33581,6 +33581,29 @@  (define-public emacs-helm-notmuch
 real search.")
     (license license:gpl3+)))
 
+(define-public emacs-notmuch-addr
+  (package
+    (name "emacs-notmuch-addr")
+    (version "1.1.0")
+    (home-page "https://github.com/tarsius/notmuch-addr")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url home-page)
+             (commit "7dde87a44b6576eb736cb6a3b69df6b9946c5ecc")))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "1xr78yw679swbl1bcwhk5k6qj1l9zr9nyl34ry2bpdryi370zkkp"))))
+    (build-system emacs-build-system)
+    (propagated-inputs (list emacs-compat emacs-notmuch))
+    (synopsis "Improved address completion for Notmuch")
+    (description
+     "A simple alternative to @code{notmuch-address}.  It gives up on
+persistent caching, external scripts, and backward compatibility.  It uses the
+improved completion API offered by Emacs 27.1 and later.")
+    (license license:gpl3+)))
+
 (define-public emacs-notmuch-indicator
   (package
     (name "emacs-notmuch-indicator")