[bug#77949,v3,3/5] gnu: Remove utf8proc-2.7.0.
Commit Message
* gnu/packages/textutils.scm (utf8proc-2.7.0): Remove utf8proc-2.7.0.
Change-Id: I1c27646cdded84370590b12e5e65eddcdf97a1e7
---
gnu/packages/textutils.scm | 40 --------------------------------------
1 file changed, 40 deletions(-)
@@ -251,46 +251,6 @@ (define-public utf8proc
"DerivedCoreProperties.txt"))))))))
(properties (alist-delete 'hidden? (package-properties utf8proc-bootstrap)))))
-(define-public utf8proc-2.7.0
- (package
- (inherit utf8proc)
- (name "utf8proc")
- (version "2.7.0")
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/JuliaStrings/utf8proc")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32 "1wrsmnaigal94gc3xbzdrrm080zjhihjfdla5admllq2w5dladjj"))))
- (arguments
- (substitute-keyword-arguments (package-arguments utf8proc)
- ((#:phases phases)
- `(modify-phases ,phases
- (replace 'check-data
- (lambda* (#:key inputs native-inputs #:allow-other-keys)
- (display native-inputs)
- (for-each (lambda (i)
- (copy-file (assoc-ref (or native-inputs inputs) i)
- (string-append "data/" i)))
- '("NormalizationTest.txt" "GraphemeBreakTest.txt"
- "DerivedCoreProperties.txt"))))))))
- (native-inputs
- (append
- (package-native-inputs utf8proc)
- (let ((UNICODE_VERSION "14.0.0"))
- `(("DerivedCoreProperties.txt"
- ,(origin
- (method url-fetch)
- (uri (string-append "https://www.unicode.org/Public/"
- UNICODE_VERSION "/ucd/DerivedCoreProperties.txt"))
- (sha256
- (base32 "1g77s8g9443dd92f82pbkim7rk51s7xdwa3mxpzb1lcw8ryxvvg3"))))
- ;; For tests
- ("ruby" ,ruby-2.7)))))))
-
(define-public libconfuse
(package
(name "libconfuse")