diff mbox series

[bug#69486] gnu: Add python-pypugjs.

Message ID 2973fb0b7bacc392c1c2a3a5bdb7539f19c33268.1709284746.git.tanguy@bioneland.org
State New
Headers show
Series [bug#69486] gnu: Add python-pypugjs. | expand

Commit Message

Tanguy LE CARROUR March 1, 2024, 9:22 a.m. UTC
Hi Guix,

This patch adds PyPugJS. Not much more to say, except… thanks for
reviewing! 😉

Tanguy

* gnu/packages/python-xyz.scm (python-pypugjs): New variable.

Change-Id: I050ab42d0149fcffddcf6b12dd9c1ddea23f84c9
---
 gnu/packages/python-xyz.scm | 48 +++++++++++++++++++++++++++++++++++++
 1 file changed, 48 insertions(+)


base-commit: a3a7d51a31957f185e4e6e3059610769d48ffd70
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 8691f70375..338bc72582 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -6098,6 +6098,54 @@  (define-public python-jinja2-time
 templates.  A format string can be provided to control the output.")
     (license license:expat)))
 
+(define-public python-pypugjs
+  (package
+    (name "python-pypugjs")
+    (version "5.9.12")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/kakulukia/pypugjs")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "0zj7a560h973cl7brfw1nmyhgm8rp8j80wnih0shvhmw4ql23lpa"))))
+    (build-system pyproject-build-system)
+    (arguments
+     (list
+      #:phases #~(modify-phases %standard-phases
+                   ;; Our pyramid is outdated and pyramid-mako is not packaged.
+                   (add-after 'unpack 'disable-pyramid
+                     (lambda* (#:key inputs #:allow-other-keys)
+                       (substitute* "setup.py"
+                         (("'pyramid")
+                          "#'pyramid"))))
+                   (replace 'check
+                     (lambda* (#:key tests? #:allow-other-keys)
+                       (when tests?
+                         (invoke "python" "-m" "pytest" "-v"
+                                 "pypugjs/testsuite/")))))))
+    (native-inputs (list python-coverage
+                         python-django
+                         python-jinja2
+                         python-flake8
+                         python-flask
+                         python-mako
+                         python-nose
+                         python-pip
+                         python-poetry-core
+                         python-pytest
+                         python-setuptools
+                         python-tornado-6
+                         python-wheel))
+    (propagated-inputs (list python-charset-normalizer python-six))
+    (home-page "https://github.com/kakulukia/pypugjs")
+    (synopsis "Convert Pug source files into different template languages")
+    (description
+     "PugJS syntax template adapter for Django, Jinja2, Mako and Tornado templates.")
+    (license license:expat))) ;; MIT
+
 (define-public python-pysdl2
   (package
     (name "python-pysdl2")