diff mbox series

[bug#38901] gnu: Add gupnp-dlna.

Message ID 2972759a14e35cfb233d95b8f748e5b276e275be.camel@disroot.org
State Accepted
Headers show
Series [bug#38901] gnu: Add gupnp-dlna. | expand

Checks

Context Check Description
cbaines/applying patch fail Apply failed

Commit Message

Raghav Gururajan Jan. 3, 2020, 4:39 p.m. UTC
Hello Guix!

Please find the attached patch to add gupnp-dlna.

NOTE: This patch depends on patch #38898.

Regards,
RG.

Comments

Raghav Gururajan Jan. 13, 2020, 1:25 a.m. UTC | #1
v2
Danny Milosavljevic Jan. 13, 2020, 8:07 a.m. UTC | #2
Pushed to guix master as commit 47607ec8744a97021df1e5dd3be31f664d0b9f28
after moving gst-plugins-bad and gst-plugins-good to propagated-inputs.
diff mbox series

Patch

From 17b5f8a4cebb70f7900ed70c034b89f55f48a87c Mon Sep 17 00:00:00 2001
From: Raghav Gururajan <raghavgururajan@disroot.org>
Date: Fri, 3 Jan 2020 11:34:53 -0500
Subject: [PATCH] gnu: Add gupnp-dlna.

* gnu/packages/gnome.scm (gupnp-dlna): New variable.
---
 gnu/packages/gnome.scm | 34 ++++++++++++++++++++++++++++++++++
 1 file changed, 34 insertions(+)

diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index a4f3a32d90..757091790d 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -335,6 +335,40 @@  the handling and implementation of UPnP A/V profiles.")
    (home-page "https://gitlab.gnome.org/GNOME/gupnp-av")
    (license license:gpl2)))
 
+(define-public gupnp-dlna
+  (package
+   (name "gupnp-dlna")
+   (version "0.10.5")
+   (source (origin
+            (method url-fetch)
+            (uri (string-append "mirror://gnome/sources/" name "/"
+                                (version-major+minor version) "/"
+                                name "-" version ".tar.xz"))
+            (sha256
+             (base32
+              "0spzd2saax7w776p5laixdam6d7smyynr9qszhbmq7f14y13cghj"))))
+   (build-system gnu-build-system)
+   (native-inputs
+    `(("gettext" ,gettext-minimal)
+      ("glib:bin" ,glib "bin")
+      ("pkg-config" ,pkg-config)))
+   (inputs
+    `(("gtk-doc" ,gtk-doc)
+      ("gobject-introspection" ,gobject-introspection)
+      ("gst-plugins-base" ,gst-plugins-base)
+      ("gst-plugins-good" ,gst-plugins-good)
+      ("gstreamer" ,gstreamer)
+      ("gtk+" ,gtk+)
+      ("gupnp" ,gupnp)
+      ("libxml" ,libxml2)
+      ("vala" ,vala)))
+   (synopsis "GUPnP DLNA for GNOME desktop")
+   (description "GUPnP DLNA is a small utility library that aims to ease
+the DLNA-related tasks such as media profile guessing, transcoding to a
+given profile, etc.")
+   (home-page "https://gitlab.gnome.org/GNOME/gupnp-dlna")
+   (license license:gpl2+)))
+
 (define-public libmediaart
   (package
     (name "libmediaart")
-- 
2.24.1