From 17b5f8a4cebb70f7900ed70c034b89f55f48a87c Mon Sep 17 00:00:00 2001
From: Raghav Gururajan <raghavgururajan@disroot.org>
Date: Fri, 3 Jan 2020 11:34:53 -0500
Subject: [PATCH] gnu: Add gupnp-dlna.
* gnu/packages/gnome.scm (gupnp-dlna): New variable.
---
gnu/packages/gnome.scm | 34 ++++++++++++++++++++++++++++++++++
1 file changed, 34 insertions(+)
@@ -335,6 +335,40 @@ the handling and implementation of UPnP A/V profiles.")
(home-page "https://gitlab.gnome.org/GNOME/gupnp-av")
(license license:gpl2)))
+(define-public gupnp-dlna
+ (package
+ (name "gupnp-dlna")
+ (version "0.10.5")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://gnome/sources/" name "/"
+ (version-major+minor version) "/"
+ name "-" version ".tar.xz"))
+ (sha256
+ (base32
+ "0spzd2saax7w776p5laixdam6d7smyynr9qszhbmq7f14y13cghj"))))
+ (build-system gnu-build-system)
+ (native-inputs
+ `(("gettext" ,gettext-minimal)
+ ("glib:bin" ,glib "bin")
+ ("pkg-config" ,pkg-config)))
+ (inputs
+ `(("gtk-doc" ,gtk-doc)
+ ("gobject-introspection" ,gobject-introspection)
+ ("gst-plugins-base" ,gst-plugins-base)
+ ("gst-plugins-good" ,gst-plugins-good)
+ ("gstreamer" ,gstreamer)
+ ("gtk+" ,gtk+)
+ ("gupnp" ,gupnp)
+ ("libxml" ,libxml2)
+ ("vala" ,vala)))
+ (synopsis "GUPnP DLNA for GNOME desktop")
+ (description "GUPnP DLNA is a small utility library that aims to ease
+the DLNA-related tasks such as media profile guessing, transcoding to a
+given profile, etc.")
+ (home-page "https://gitlab.gnome.org/GNOME/gupnp-dlna")
+ (license license:gpl2+)))
+
(define-public libmediaart
(package
(name "libmediaart")
--
2.24.1