diff mbox series

[bug#43125] Re: [PATCH] Add new font APL385 & APL333

Message ID 296a2407.745f.175b180247e.Coremail.all_but_last@163.com
State New
Headers show
Series [bug#43125] Re: [PATCH] Add new font APL385 & APL333 | expand

Checks

Context Check Description
cbaines/submitting builds success
cbaines/issue success View issue
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job

Commit Message

Zhu Zihao Nov. 10, 2020, 9:32 a.m. UTC
Ludo, Can you please help review this patch? It's been idle for a long long time, Thanks a lot.











在 2020-08-31 12:27:19,"Zhu Zihao" <all_but_last@163.com> 写道:

From f4745ab244032643bcdbe00ea91e5bfe550f8dad Mon Sep 17 00:00:00 2001
From: Zhu Zihao <all_but_last@163.com>
Date: Mon, 31 Aug 2020 11:39:31 +0800
Subject: [PATCH 1/2] gnu: Add font-apl385

* gnu/packages/fonts.scm (font-apl385): New variable.
---
 gnu/packages/fonts.scm | 19 +++++++++++++++++++
 1 file changed, 19 insertions(+)

--
2.27.0

Comments

Julien Lepiller Nov. 10, 2020, 11:58 a.m. UTC | #1
Hi,

I've tried to apply and build these fonts. Apl 385 applied and built
without any issue, but it seems that apl333 sources have changed since
you posted your patch.

Apparently, they update the archives in-place, which is a bad practice
for distros such as ours, since it will break our packaging system at
an unknown time in the future. Do you know of any other source for
these fonts with versionned archives? Do you know how to contact the
author, to ask them for a versionned link?

Le Tue, 10 Nov 2020 17:32:46 +0800 (CST),
"Zhu Zihao" <all_but_last@163.com> a écrit :

> Ludo, Can you please help review this patch? It's been idle for a
> long long time, Thanks a lot.
> 
> 
> 
> 
> 
> 
> 
> 
> 
> 
> 
> 在 2020-08-31 12:27:19,"Zhu Zihao" <all_but_last@163.com> 写道:
> 
> From f4745ab244032643bcdbe00ea91e5bfe550f8dad Mon Sep 17 00:00:00 2001
> From: Zhu Zihao <all_but_last@163.com>
> Date: Mon, 31 Aug 2020 11:39:31 +0800
> Subject: [PATCH 1/2] gnu: Add font-apl385
> 
> * gnu/packages/fonts.scm (font-apl385): New variable.
> ---
>  gnu/packages/fonts.scm | 19 +++++++++++++++++++
>  1 file changed, 19 insertions(+)
> 
> diff --git a/gnu/packages/fonts.scm b/gnu/packages/fonts.scm
> index 77484157e3..794d988df2 100644
> --- a/gnu/packages/fonts.scm
> +++ b/gnu/packages/fonts.scm
> @@ -1961,3 +1961,22 @@ operators and special symbols.")
>  is a stylish type with a polished yet relaxed feel.  Its versatility
> makes it suitable for a wide range of uses.")
>        (license license:silofl1.1))))
> +
> +(define-public font-apl385
> +  (let ((revision "0"))
> +    (package
> +      (name "font-apl385")
> +      (version (string-append "1.0.0-" revision))
> +      (source
> +       (origin
> +         (method url-fetch/zipbomb)
> +         (uri "https://apl385.com/fonts/apl385.zip")
> +         (sha256
> +          (base32
> "132qfsnx0v6qf8x8iy3flivv449nz42nnpkwjysmz65w6wqxpk1g"))))
> +      (build-system font-build-system)
> +      (home-page "https://apl385.com")
> +      (synopsis "Monospace font for APL programming")
> +      (description "APL385 is developed with all APL software vendors
> +in the late 1980s and enhanced as required with new characters to
> meet +interpreter updates.")
> +      (license license:public-domain))))
> --
> 2.27.0
> 
> 
> 
> 
> 
> 
> 
> From 952a5b50902eab13c43599de44c1b4ac501c71df Mon Sep 17 00:00:00 2001
> From: Zhu Zihao <all_but_last@163.com>
> Date: Mon, 31 Aug 2020 11:40:49 +0800
> Subject: [PATCH 2/2] gnu: Add font-apl333
> 
> * gnu/packages/fonts.scm (font-apl333): New variable.
> ---
>  gnu/packages/fonts.scm | 17 +++++++++++++++++
>  1 file changed, 17 insertions(+)
> 
> diff --git a/gnu/packages/fonts.scm b/gnu/packages/fonts.scm
> index 794d988df2..e61a0d2f4a 100644
> --- a/gnu/packages/fonts.scm
> +++ b/gnu/packages/fonts.scm
> @@ -1980,3 +1980,20 @@ suitable for a wide range of uses.")
>  in the late 1980s and enhanced as required with new characters to
> meet interpreter updates.")
>        (license license:public-domain))))
> +
> +(define-public font-apl333
> +  (let ((revision "0"))
> +    (package
> +      (name "font-apl333")
> +      (version (string-append "1.0.0-" revision))
> +      (source
> +       (origin
> +         (method url-fetch/zipbomb)
> +         (uri "https://apl385.com/fonts/apl333.zip")
> +         (sha256
> +          (base32
> "132qfsnx0v6qf8x8iy3flivv449nz42nnpkwjysmz65w6wqxpk1g"))))
> +      (build-system font-build-system)
> +      (home-page "https://apl385.com")
> +      (synopsis "Proportional font for APL programming")
> +      (description "APL333 is the proportional variant of APL385.")
> +      (license license:public-domain))))
> --
> 2.27.0
> 
> 
> 
> 
> 
> 
> 
>
Zhu Zihao Nov. 10, 2020, 2:15 p.m. UTC | #2
Sadly I can't contact them, because they leave no contact at the site.
:(

I' ll email you if I can find a way to retrieve source
deterministically, thanks.

Julien Lepiller writes:

> Hi,
>
> I've tried to apply and build these fonts. Apl 385 applied and built
> without any issue, but it seems that apl333 sources have changed since
> you posted your patch.
>
> Apparently, they update the archives in-place, which is a bad practice
> for distros such as ours, since it will break our packaging system at
> an unknown time in the future. Do you know of any other source for
> these fonts with versionned archives? Do you know how to contact the
> author, to ask them for a versionned link?
>
> Le Tue, 10 Nov 2020 17:32:46 +0800 (CST),
> "Zhu Zihao" <all_but_last@163.com> a écrit :
>
Leo Famulari Nov. 17, 2020, 8:17 p.m. UTC | #3
If you don't find another method, you could upload the source code to
archive.org and make the Guix package fetch from there. We've done that
before to work around this kind of problem.

On Tue, Nov 10, 2020 at 10:15:38PM +0800, Zhu Zihao wrote:
> 
> Sadly I can't contact them, because they leave no contact at the site.
> :(
> 
> I' ll email you if I can find a way to retrieve source
> deterministically, thanks.
> 
> Julien Lepiller writes:
> 
> > Hi,
> >
> > I've tried to apply and build these fonts. Apl 385 applied and built
> > without any issue, but it seems that apl333 sources have changed since
> > you posted your patch.
> >
> > Apparently, they update the archives in-place, which is a bad practice
> > for distros such as ours, since it will break our packaging system at
> > an unknown time in the future. Do you know of any other source for
> > these fonts with versionned archives? Do you know how to contact the
> > author, to ask them for a versionned link?
> >
> > Le Tue, 10 Nov 2020 17:32:46 +0800 (CST),
> > "Zhu Zihao" <all_but_last@163.com> a écrit :
> >
> 
> 
> -- 
> Retrieve my PGP public key: https://meta.sr.ht/~citreu.pgp
> 
> Zihao
Simon Tournier Nov. 17, 2020, 11:45 p.m. UTC | #4
Hi,


On Tue, 17 Nov 2020 at 15:17, Leo Famulari <leo@famulari.name> wrote:

> If you don't find another method, you could upload the source code to
> archive.org and make the Guix package fetch from there. We've done that
> before to work around this kind of problem.

What have been done recently for case where the upstream is not
available anymore is: convert to Git and save to Software Heritage.

For instance, see commit 74cb33c22818b25d1b9c6d576352fc8249832d34 and

   <http://issues.guix.gnu.org/issue/43426>

especially this snippet:

--8<---------------cut here---------------start------------->8---
$ (cd /tmp; tar xf $(guix build -S gdsl); guix hash -r /tmp/gdsl-1.8)
0a52g12d9sf9hhcyvwfd7xdazj2a9i9jh97cnlqf2ymvwnvjk1g0
$ guix hash -r $(./pre-inst-env guix build -S gdsl)
0a52g12d9sf9hhcyvwfd7xdazj2a9i9jh97cnlqf2ymvwnvjk1g0
--8<---------------cut here---------------end--------------->8---

Obviously, need tweaks for the issue at hand. :-)

All the best,
simon
diff mbox series

Patch

diff --git a/gnu/packages/fonts.scm b/gnu/packages/fonts.scm
index 77484157e3..794d988df2 100644
--- a/gnu/packages/fonts.scm
+++ b/gnu/packages/fonts.scm
@@ -1961,3 +1961,22 @@  operators and special symbols.")
 is a stylish type with a polished yet relaxed feel.  Its versatility makes it
 suitable for a wide range of uses.")
       (license license:silofl1.1))))
+
+(define-public font-apl385
+  (let ((revision "0"))
+    (package
+      (name "font-apl385")
+      (version (string-append "1.0.0-" revision))
+      (source
+       (origin
+         (method url-fetch/zipbomb)
+         (uri "https://apl385.com/fonts/apl385.zip")
+         (sha256
+          (base32 "132qfsnx0v6qf8x8iy3flivv449nz42nnpkwjysmz65w6wqxpk1g"))))
+      (build-system font-build-system)
+      (home-page "https://apl385.com")
+      (synopsis "Monospace font for APL programming")
+      (description "APL385 is developed with all APL software vendors
+in the late 1980s and enhanced as required with new characters to meet
+interpreter updates.")
+      (license license:public-domain))))
--
2.27.0







From 952a5b50902eab13c43599de44c1b4ac501c71df Mon Sep 17 00:00:00 2001
From: Zhu Zihao <all_but_last@163.com>
Date: Mon, 31 Aug 2020 11:40:49 +0800
Subject: [PATCH 2/2] gnu: Add font-apl333

* gnu/packages/fonts.scm (font-apl333): New variable.
---
 gnu/packages/fonts.scm | 17 +++++++++++++++++
 1 file changed, 17 insertions(+)

diff --git a/gnu/packages/fonts.scm b/gnu/packages/fonts.scm
index 794d988df2..e61a0d2f4a 100644
--- a/gnu/packages/fonts.scm
+++ b/gnu/packages/fonts.scm
@@ -1980,3 +1980,20 @@  suitable for a wide range of uses.")
 in the late 1980s and enhanced as required with new characters to meet
 interpreter updates.")
       (license license:public-domain))))
+
+(define-public font-apl333
+  (let ((revision "0"))
+    (package
+      (name "font-apl333")
+      (version (string-append "1.0.0-" revision))
+      (source
+       (origin
+         (method url-fetch/zipbomb)
+         (uri "https://apl385.com/fonts/apl333.zip")
+         (sha256
+          (base32 "132qfsnx0v6qf8x8iy3flivv449nz42nnpkwjysmz65w6wqxpk1g"))))
+      (build-system font-build-system)
+      (home-page "https://apl385.com")
+      (synopsis "Proportional font for APL programming")
+      (description "APL333 is the proportional variant of APL385.")
+      (license license:public-domain))))