diff mbox series

[bug#36658] gnu: Add emacs-zerodark-theme.

Message ID 29622ca8a83facccb8744c132c2b413eb63515ab.camel@autistici.org
State Accepted
Headers show
Series [bug#36658] gnu: Add emacs-zerodark-theme. | expand

Commit Message

Giacomo Leidi July 19, 2019, 10:30 a.m. UTC
Hello,

I'm not sure why but I was convinced that guix import would run guix
lint on the generated package, so I didn't even try to run it. I'll pay
more attention next time.

The attached patch should fix all previous problems.

Thank you for your review!

Giacomo




On Wed, 2019-07-17 at 15:35 +0200, Ludovic Courtès wrote:
> Hello,
> 
> Giacomo Leidi <goodoldpaul@autistici.org> skribis:
> 
> > * gnu/packages/emacs-xyz.scm (emacs-zerodark-theme): New variable.
> 
> Thanks for this patch!  Below are a couple of suggestions.
> 
> > +(define-public emacs-zerodark-theme
> > +  (package
> > +  (name "emacs-zerodark-theme")
> 
>      ^
> The indentation is off here (you can do M-q to fix it if you use
> paredit).
> 
> > +  (version "20190528.923")
> > +  (source
> > +    (origin
> > +      (method url-fetch)
> > +      (uri (string-append
> > +             "https://melpa.org/packages/zerodark-theme-"
> > +             version
> > +             ".el"))
> 
> This URL is unstable: the file will be modified in place regularly.
> Consequently, could you instead use the upstream Git repository URL
> along with the ‘git-fetch’ method?
> 
> > +  (synopsis
> > +    "A dark, medium contrast theme for Emacs")
> 
>         ^
> Please remove “A”, as suggested by ‘guix lint’.
> 
> > +  (description
> > +    "A dark theme inspired from One Dark and Niflheim.
> 
> Please write a full sentence (info "(guix) Synopses and
> Descriptions").
> 
> > +An optional mode-line format can be enabled with 'zerodark-setup-
> > modeline-format'.")
> 
>                                                     ^
> Please use @code as suggested by ‘guix lint’.
> 
> Could you send an updated patch?
> 
> Thanks!
> 
> Ludo’.

Comments

Ludovic Courtès July 19, 2019, 10:59 p.m. UTC | #1
Hi,

Tino il Cotechino <goodoldpaul@autistici.org> skribis:

> From 392b3a7c34198f47f19fb6b678662971aa8a371f Mon Sep 17 00:00:00 2001
> From: Giacomo Leidi <goodoldpaul@autistici.org>
> Date: Mon, 15 Jul 2019 11:21:24 +0200
> Subject: [PATCH] gnu: Add emacs-zerodark-theme.
>
> * gnu/packages/emacs-xyz.scm (emacs-zerodark-theme): New variable.

Applied, thanks!

Ludo’.
diff mbox series

Patch

From 392b3a7c34198f47f19fb6b678662971aa8a371f Mon Sep 17 00:00:00 2001
From: Giacomo Leidi <goodoldpaul@autistici.org>
Date: Mon, 15 Jul 2019 11:21:24 +0200
Subject: [PATCH] gnu: Add emacs-zerodark-theme.

* gnu/packages/emacs-xyz.scm (emacs-zerodark-theme): New variable.
---
 gnu/packages/emacs-xyz.scm | 27 +++++++++++++++++++++++++++
 1 file changed, 27 insertions(+)

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 47edbaeeb6..fe4c3a6cd4 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -49,6 +49,7 @@ 
 ;;; Copyright © 2019 LaFreniere, Joseph <joseph@lafreniere.xyz>
 ;;; Copyright © 2019 Amar Singh <nly@disroot.org>
 ;;; Copyright © 2019 Baptiste Strazzulla <bstrazzull@hotmail.fr>
+;;; Copyright © 2019 Giacomo Leidi <goodoldpaul@autitici.org>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -16564,3 +16565,29 @@  directories, direct visualisation of image files, jumping directly to links by
 name (with autocompletion), a simple bookmark management system and
 connections using TLS encryption.")
     (license license:gpl3+)))
+
+(define-public emacs-zerodark-theme
+  (package
+    (name "emacs-zerodark-theme")
+    (version "4.5")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://gitlab.petton.fr/nico/zerodark-theme.git")
+             (commit version)))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32
+         "0nnlxzsmhsbszqigcyxak9i1a0digrd13gv6v18ck4h760mihh1m"))))
+    (build-system emacs-build-system)
+    (propagated-inputs
+     `(("emacs-all-the-icons" ,emacs-all-the-icons)))
+    (home-page
+     "https://gitlab.petton.fr/nico/zerodark-theme")
+    (synopsis
+     "Dark, medium contrast theme for Emacs")
+    (description
+     "Zerodark is a dark theme inspired from One Dark and Niflheim.
+An optional mode-line format can be enabled with @code{zerodark-setup-modeline-format}.")
+    (license license:gpl3+)))
-- 
2.22.0