diff mbox series

[bug#74391,2/2] gnu: sslh: Use GEXPs.

Message ID 2924c8c2d1d1ee64f90867729d837724edf98119.1731833680.git.poptsov.artyom@gmail.com
State New
Headers show
Series gnu: sslh: Update to 2.1.2. | expand

Commit Message

Artyom V. Poptsov Nov. 17, 2024, 9:02 a.m. UTC
* gnu/packages/networking.scm (sslh): Use GEXPs.

Change-Id: I5b31afdfeb1f1f9b2e5f86290adc405f3a90a367
---
 gnu/packages/networking.scm | 61 ++++++++++++++++++-------------------
 1 file changed, 29 insertions(+), 32 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
index 091ed06d3d..6017654866 100644
--- a/gnu/packages/networking.scm
+++ b/gnu/packages/networking.scm
@@ -2740,38 +2740,35 @@  (define-public sslh
     (inputs
      (list libev libconfig pcre))
     (arguments
-     `(#:phases
-       (modify-phases %standard-phases
-         (add-before 'check 'fix-tests
-           (lambda _
-             (substitute* "t"
-               ;; XXX: Disable a failing test.
-               (("my \\$DROP_CNX =          1;")
-                "my $DROP_CNX =          0;")
-               ;; XXX: "sslh-select" seems to not support this option for some
-               ;; reason.  According to "sslhconf.cfg" this option just overrides the
-               ;; verbosity configuration so it seems that we can safely drop it.
-               (("-v 4")
-                ""))
-             (substitute* "test.cfg"
-               ;; The Guix build environment lacks ‘ip4-localhost’.
-               (("ip4-localhost") "localhost"))
-             #t))
-         ;; Many of these files are mentioned in the man page. Install them.
-         (add-after 'install 'install-documentation
-           (lambda* (#:key outputs #:allow-other-keys)
-             (let* ((out (assoc-ref outputs "out"))
-                    (doc (string-append out "/share/doc/sslh")))
-               (install-file "README.md" doc)
-               (for-each
-                (lambda (file)
-                  (install-file file (string-append doc "/examples")))
-                (append (find-files "." "\\.cfg")
-                        (find-files "scripts"))))
-             #t)))
-       #:make-flags (list ,(string-append "CC=" (cc-for-target))
-                          "USELIBCONFIG=1"
-                          (string-append "PREFIX=" (assoc-ref %outputs "out")))
+     (list #:phases
+           #~(modify-phases %standard-phases
+               (add-before 'check 'fix-tests
+                 (lambda _
+                   (substitute* "t"
+                     ;; XXX: Disable a failing test.
+                     (("my \\$DROP_CNX =          1;")
+                      "my $DROP_CNX =          0;")
+                     ;; XXX: "sslh-select" seems to not support this option for some
+                     ;; reason.  According to "sslhconf.cfg" this option just overrides the
+                     ;; verbosity configuration so it seems that we can safely drop it.
+                     (("-v 4")
+                      ""))
+                   (substitute* "test.cfg"
+                     ;; The Guix build environment lacks ‘ip4-localhost’.
+                     (("ip4-localhost") "localhost"))))
+               ;; Many of these files are mentioned in the man page. Install them.
+               (add-after 'install 'install-documentation
+                 (lambda _
+                   (let* ((doc (string-append #$output "/share/doc/sslh")))
+                     (install-file "README.md" doc)
+                     (for-each
+                      (lambda (file)
+                        (install-file file (string-append doc "/examples")))
+                      (append (find-files "." "\\.cfg")
+                              (find-files "scripts")))))))
+           #:make-flags #~(list (string-append "CC=" #$(cc-for-target))
+                                "USELIBCONFIG=1"
+                                (string-append "PREFIX=" #$output))
        #:test-target "test"))
     (home-page "https://www.rutschle.net/tech/sslh/README.html")
     (synopsis "Applicative network protocol demultiplexer")