diff mbox series

[bug#67834] gnu: Add node-path-key.

Message ID 28aa90fdad4f200b663ac5b4fc72fed6a9bea2fb.1702486890.git.hrn@posteo.net
State New
Headers show
Series [bug#67834] gnu: Add node-path-key. | expand

Commit Message

hrn Dec. 15, 2023, 7:29 a.m. UTC
* gnu/packages/node-xyz.scm (node-path-key): New variable

Change-Id: I0fc1cbbcf82622f4bf2dd6d2ca46b22605ea964a
---
 gnu/packages/node-xyz.scm | 25 +++++++++++++++++++++++++
 1 file changed, 25 insertions(+)


base-commit: 23627b1706af25a0a30b96b9169a3495279aff1b

Comments

Jelle Licht Feb. 3, 2024, 5:09 p.m. UTC | #1
Rikard Nordgren <hrn@posteo.net> writes:

> * gnu/packages/node-xyz.scm (node-path-key): New variable
>
> Change-Id: I0fc1cbbcf82622f4bf2dd6d2ca46b22605ea964a

Thanks! Pushed to master, I slightly reworded the package description
(hopefully for the better).

- Jelle
diff mbox series

Patch

diff --git a/gnu/packages/node-xyz.scm b/gnu/packages/node-xyz.scm
index 6c16417309..9146daef8a 100644
--- a/gnu/packages/node-xyz.scm
+++ b/gnu/packages/node-xyz.scm
@@ -631,6 +631,31 @@  (define-public node-once
 if desired.")
     (license license:isc)))
 
+(define-public node-path-key
+  (package
+    (name "node-path-key")
+    (version "4.0.0")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/sindresorhus/path-key")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "09f4rf70qhq234fcc3pw9nrqic8cb75pk2b6wfnpr96v0r1h8d8g"))))
+    (build-system node-build-system)
+    (arguments
+     '(#:tests? #f
+       #:phases (modify-phases %standard-phases
+                  (add-after 'patch-dependencies 'delete-dependencies
+                    (lambda _
+                      (delete-dependencies '("@types/node" "ava" "tsd" "xo")))))))
+    (home-page "https://github.com/sindresorhus/path-key")
+    (synopsis "Get the PATH environment variable key cross-platform")
+    (description "Get the PATH environment variable key cross-platform")
+    (license license:expat)))
+
 (define-public node-ieee754
   (package
     (name "node-ieee754")