diff mbox series

[bug#39108] gnu: Add gst-editing-services.

Message ID 28a17d6a51b46ed190c544de7f357ec7cff44ae9.camel@student.tugraz.at
State Accepted
Headers show
Series [bug#39108] gnu: Add gst-editing-services. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job

Commit Message

Leo Prikler Feb. 14, 2020, 4:09 p.m. UTC
Am Freitag, den 14.02.2020, 16:58 +0100 schrieb Marius Bakke:
> Oh no, I missed that you had alredy ported GStreamer to the Meson
> build
> system in a previous email!  Sorry for the duplicate work.
> 
> I notice in this patch that gst-editing-services still uses
> gnu-build-system, can you update it to use meson-build-system
> instead?
Ahh, my bad.  Updated version is attached.

Comments

Marius Bakke Feb. 14, 2020, 4:12 p.m. UTC | #1
Leo Prikler <leo.prikler@student.tugraz.at> writes:

> Am Freitag, den 14.02.2020, 16:58 +0100 schrieb Marius Bakke:
>> Oh no, I missed that you had alredy ported GStreamer to the Meson
>> build
>> system in a previous email!  Sorry for the duplicate work.
>> 
>> I notice in this patch that gst-editing-services still uses
>> gnu-build-system, can you update it to use meson-build-system
>> instead?
> Ahh, my bad.  Updated version is attached.

I'm getting a strange build failure with this patch:


...
Dependency gstreamer-plugins-base-1.0 found: YES 1.16.2
Dependency gstreamer-plugins-bad-1.0 found: NO (tried pkgconfig and cmake)

tests/check/meson.build:41:2: ERROR: 'not-found' is not a pkgconfig dependency

A full log can be found at /tmp/guix-build-gst-editing-services-1.16.2.drv-0/build/meson-logs/meson-log.txt

I suppose it needs 'gst-plugins-bad'?
diff mbox series

Patch

From b4a43af80e52a63919c3697700f80b73e91bfddb Mon Sep 17 00:00:00 2001
From: Leo Prikler <leo.prikler@student.tugraz.at>
Date: Sun, 12 Jan 2020 18:42:24 +0100
Subject: [PATCH] gnu: Add gst-editing-services.

* gnu/packages/gstreamer.scm (gst-editing-services): New variable.
---
 gnu/packages/gstreamer.scm | 31 +++++++++++++++++++++++++++++++
 1 file changed, 31 insertions(+)

diff --git a/gnu/packages/gstreamer.scm b/gnu/packages/gstreamer.scm
index 1e26a3c..f33e125 100644
--- a/gnu/packages/gstreamer.scm
+++ b/gnu/packages/gstreamer.scm
@@ -476,6 +476,37 @@  distribution problems in some jurisdictions, e.g. due to patent threats.")
 compression formats through the use of the libav library.")
     (license license:gpl2+)))
 
+(define-public gst-editing-services
+  (package
+    (name "gst-editing-services")
+    (version "1.16.2")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append
+                    "https://gstreamer.freedesktop.org/src/" name "/"
+                    "gstreamer-editing-services-" version ".tar.xz"))
+              (sha256
+               (base32
+                "05hcf3prna8ajjnqd53221gj9syarrrjbgvjcbhicv0c38csc1hf"))))
+    (build-system meson-build-system)
+    (arguments
+     ;; TODO: 16/22 failing tests
+     `(#:tests? #f))
+    (inputs
+     `(("gst-plugins-base" ,gst-plugins-base)
+       ("libxml2" ,libxml2)))
+    (native-inputs
+     `(("flex" ,flex)
+       ("perl" ,perl)
+       ("pkg-config" ,pkg-config)
+       ("python" ,python)))
+    (home-page "https://gstreamer.freedesktop.org/")
+    (synopsis "GStreamer library for non-linear editors")
+    (description
+     "This is a high-level library for facilitating the creation of audio/video
+non-linear editors.")
+    (license license:gpl2+)))
+
 (define-public python-gst
   (package
     (name "python-gst")
--
libgit2 0.28.4