From b4a43af80e52a63919c3697700f80b73e91bfddb Mon Sep 17 00:00:00 2001
From: Leo Prikler <leo.prikler@student.tugraz.at>
Date: Sun, 12 Jan 2020 18:42:24 +0100
Subject: [PATCH] gnu: Add gst-editing-services.
* gnu/packages/gstreamer.scm (gst-editing-services): New variable.
---
gnu/packages/gstreamer.scm | 31 +++++++++++++++++++++++++++++++
1 file changed, 31 insertions(+)
@@ -476,6 +476,37 @@ distribution problems in some jurisdictions, e.g. due to patent threats.")
compression formats through the use of the libav library.")
(license license:gpl2+)))
+(define-public gst-editing-services
+ (package
+ (name "gst-editing-services")
+ (version "1.16.2")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://gstreamer.freedesktop.org/src/" name "/"
+ "gstreamer-editing-services-" version ".tar.xz"))
+ (sha256
+ (base32
+ "05hcf3prna8ajjnqd53221gj9syarrrjbgvjcbhicv0c38csc1hf"))))
+ (build-system meson-build-system)
+ (arguments
+ ;; TODO: 16/22 failing tests
+ `(#:tests? #f))
+ (inputs
+ `(("gst-plugins-base" ,gst-plugins-base)
+ ("libxml2" ,libxml2)))
+ (native-inputs
+ `(("flex" ,flex)
+ ("perl" ,perl)
+ ("pkg-config" ,pkg-config)
+ ("python" ,python)))
+ (home-page "https://gstreamer.freedesktop.org/")
+ (synopsis "GStreamer library for non-linear editors")
+ (description
+ "This is a high-level library for facilitating the creation of audio/video
+non-linear editors.")
+ (license license:gpl2+)))
+
(define-public python-gst
(package
(name "python-gst")
--
libgit2 0.28.4