@@ -334,37 +334,6 @@ (define-public node
(define-public node-bootstrap
(hidden-package node))
-;; Duplicate of node-semver
-(define-public node-semver-bootstrap
- (package
- (name "node-semver")
- (version "7.2.1")
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/npm/node-semver")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "06biknqb05r9xsmcflm3ygh50pjvdk84x6r79w43kmck4fn3qn5p"))))
- (build-system node-build-system)
- (arguments
- `(#:node ,node-bootstrap
- #:tests? #f
- #:phases
- (modify-phases %standard-phases
- (add-after 'patch-dependencies 'delete-dependencies
- (lambda args
- (delete-dependencies '("tap")))))))
- (home-page "https://github.com/npm/node-semver")
- (properties '((hidden? . #t)))
- (synopsis "Parses semantic versions strings")
- (description
- "@code{node-semver} is a JavaScript implementation of the
-@uref{https://semver.org/, SemVer.org} specification.")
- (license license:isc)))
-
(define-public node-ms-bootstrap
(package
(name "node-ms")
base-commit: 612e4dd98f7d1d015e405af9d029bede3fe3c280
prerequisite-patch-id: a2c4661b4faa4a67c030905eee678a55a877d1a3
prerequisite-patch-id: 59f02e242a315495ea7047c6386ed4f8a686e0c2
--
2.45.1
From 058f3dd55c8c1df7adc1634f25abcb439cc295f0 Mon Sep 17 00:00:00 2001
Message-ID: <058f3dd55c8c1df7adc1634f25abcb439cc295f0.1718694047.git.ashvithshetty10@gmail.com>
In-Reply-To: <28992bda8dae74e665bfc7b7c5b877a04afd31f4.1718694047.git.ashvithshetty10@gmail.com>
References: <28992bda8dae74e665bfc7b7c5b877a04afd31f4.1718694047.git.ashvithshetty10@gmail.com>
From: Ashvith Shetty <ashvithshetty10@gmail.com>
Date: Tue, 18 Jun 2024 10:46:35 +0530
Subject: [PATCH 2/8] gnu: Remove node-llparse-bootstrap.
* gnu/packages/node.scm (node-llparse-bootstrap): Delete variable.
Change-Id: I414164d3d69cba067659c2f81d6c93f09b96f5f6
---
gnu/packages/node.scm | 64 -------------------------------------------
1 file changed, 64 deletions(-)
@@ -571,70 +571,6 @@ (define-public node-llparse-frontend-bootstrap
(description "This package is a frontend for the llparse compiler.")
(license license:expat)))
-(define-public node-llparse-bootstrap
- (package
- (name "node-llparse")
- (version "7.1.0")
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/indutny/llparse.git")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "10da273iy2if88hp79cwms6c8qpsl1fkgzll6gmqyx5yxv5mkyp6"))
- (modules '((guix build utils)))
- (snippet
- '(begin
- ;; Fix imports for esbuild.
- ;; https://github.com/evanw/esbuild/issues/477
- (substitute* '("src/compiler/index.ts"
- "src/implementation/c/node/base.ts"
- "src/implementation/c/node/table-lookup.ts"
- "src/implementation/c/compilation.ts"
- "src/implementation/c/helpers/match-sequence.ts"
- "src/implementation/c/code/mul-add.ts")
- (("\\* as assert") "assert")
- (("\\* as debugAPI") "debugAPI"))
- #t))))
- (build-system node-build-system)
- (arguments
- `(#:node ,node-bootstrap
- #:tests? #f
- #:phases
- (modify-phases %standard-phases
- (add-after 'patch-dependencies 'delete-dependencies
- (lambda args
- (delete-dependencies `("@types/debug"
- "@types/mocha"
- "@types/node"
- "esm"
- "llparse-test-fixture"
- "mocha"
- "ts-node"
- "tslint"
- "typescript"))))
- (replace 'build
- (lambda* (#:key inputs #:allow-other-keys)
- (let ((esbuild (search-input-file inputs "/bin/esbuild")))
- (invoke esbuild
- "--platform=node"
- "--outfile=lib/api.js"
- "--bundle"
- "src/api.ts")))))))
- (inputs
- (list node-debug-bootstrap node-llparse-frontend-bootstrap))
- (native-inputs
- (list esbuild))
- (home-page "https://github.com/nodejs/llparse#readme")
- (properties '((hidden? . #t)))
- (synopsis "Compile incremental parsers to C code")
- (description "This package offers an API for compiling an incremental
-parser definition into a C output.")
- (license license:expat)))
-
(define-public llhttp-bootstrap
(package
(inherit llhttp)
--
2.45.1
From 57d153fd217dc3cce4aff2d4a75ba12c4d2f7b7a Mon Sep 17 00:00:00 2001
Message-ID: <57d153fd217dc3cce4aff2d4a75ba12c4d2f7b7a.1718694047.git.ashvithshetty10@gmail.com>
In-Reply-To: <28992bda8dae74e665bfc7b7c5b877a04afd31f4.1718694047.git.ashvithshetty10@gmail.com>
References: <28992bda8dae74e665bfc7b7c5b877a04afd31f4.1718694047.git.ashvithshetty10@gmail.com>
From: Ashvith Shetty <ashvithshetty10@gmail.com>
Date: Tue, 18 Jun 2024 10:50:49 +0530
Subject: [PATCH 3/8] gnu: Remove node-llparse-frontend-bootstrap.
* gnu/packages/node.scm (node-llparse-frontend-bootstrap): Delete variable.
Change-Id: I8ac4906741fcb49a1a794c37db75735098369729
---
gnu/packages/node.scm | 62 -------------------------------------------
1 file changed, 62 deletions(-)
@@ -509,68 +509,6 @@ (define-public node-llparse-builder-bootstrap
(description "This package builds graphs for consumption by llparse.")
(license license:expat)))
-(define-public node-llparse-frontend-bootstrap
- (package
- (name "node-llparse-frontend")
- (version "3.0.0")
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/indutny/llparse-frontend.git")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32 "1rm9g4ifyip30svm5cgnf0gx7d45jgh4mpf2hkd092xhngmfvicc"))
- (modules '((guix build utils)))
- (snippet
- '(begin
- ;; Fix imports for esbuild.
- ;; https://github.com/evanw/esbuild/issues/477
- (substitute* '("src/frontend.ts"
- "src/code/field-value.ts"
- "src/container/index.ts"
- "src/container/wrap.ts"
- "src/node/sequence.ts"
- "src/node/single.ts"
- "src/node/table-lookup.ts"
- "src/trie/index.ts")
- (("\\* as assert") "assert")
- (("\\* as debugAPI") "debugAPI"))
- #t))))
- (build-system node-build-system)
- (arguments
- `(#:node ,node-bootstrap
- #:tests? #f
- #:phases
- (modify-phases %standard-phases
- (add-after 'patch-dependencies 'delete-dependencies
- (lambda args
- (delete-dependencies `("@types/debug"
- "@types/mocha"
- "@types/node"
- "mocha"
- "ts-node"
- "tslint"
- "typescript"))))
- (replace 'build
- (lambda* (#:key inputs #:allow-other-keys)
- (let ((esbuild (search-input-file inputs "/bin/esbuild")))
- (invoke esbuild
- "--platform=node"
- "--outfile=lib/frontend.js"
- "--bundle"
- "src/frontend.ts")))))))
- (inputs
- (list node-debug-bootstrap node-llparse-builder-bootstrap))
- (native-inputs
- (list esbuild))
- (home-page "https://github.com/indutny/llparse-frontend#readme")
- (properties '((hidden? . #t)))
- (synopsis "Frontend for the llparse compiler")
- (description "This package is a frontend for the llparse compiler.")
- (license license:expat)))
-
(define-public llhttp-bootstrap
(package
(inherit llhttp)
--
2.45.1
From 1676d27d96c543364617f581ac682e32c75464b7 Mon Sep 17 00:00:00 2001
Message-ID: <1676d27d96c543364617f581ac682e32c75464b7.1718694047.git.ashvithshetty10@gmail.com>
In-Reply-To: <28992bda8dae74e665bfc7b7c5b877a04afd31f4.1718694047.git.ashvithshetty10@gmail.com>
References: <28992bda8dae74e665bfc7b7c5b877a04afd31f4.1718694047.git.ashvithshetty10@gmail.com>
From: Ashvith Shetty <ashvithshetty10@gmail.com>
Date: Tue, 18 Jun 2024 10:53:54 +0530
Subject: [PATCH 4/8] gnu: Remove node-llparse-builder-bootstrap.
* gnu/packages/node.scm (node-llparse-builder-bootstrap): Delete variable.
Change-Id: I397762b1a0a0d3d249ad78633360b77d7c12cc9e
---
gnu/packages/node.scm | 70 -------------------------------------------
1 file changed, 70 deletions(-)
@@ -439,76 +439,6 @@ (define-public node-debug-bootstrap
Node.js and web browsers.")
(license license:expat)))
-(define-public node-llparse-builder-bootstrap
- (package
- (name "node-llparse-builder")
- (version "1.5.2")
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/indutny/llparse-builder.git")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "0r82iiwqsb73k2fxw7842rjjiixllxpyc6yl9cq4ma6ybkf6xmzm"))
- (modules '((guix build utils)))
- (snippet
- '(begin
- ;; FIXME: Unneeded runtime dependency.
- ;; https://github.com/indutny/llparse-builder/pull/2
- (substitute* "package.json"
- (("\"@types/debug.*,") ""))
- ;; Fix imports for esbuild.
- ;; https://github.com/evanw/esbuild/issues/477
- (substitute* '("src/node/invoke.ts"
- "src/node/base.ts"
- "src/node/consume.ts"
- "src/node/match.ts"
- "src/node/error.ts"
- "src/node/pause.ts"
- "src/edge.ts"
- "src/utils.ts"
- "src/loop-checker/index.ts"
- "src/loop-checker/lattice.ts"
- "src/code/field.ts"
- "src/span-allocator.ts")
- (("\\* as assert") "assert")
- (("\\* as debugAPI") "debugAPI"))
- #t))))
- (build-system node-build-system)
- (arguments
- `(#:node ,node-bootstrap
- #:tests? #f
- #:phases
- (modify-phases %standard-phases
- (add-after 'patch-dependencies 'delete-dependencies
- (lambda _
- (delete-dependencies `("@types/mocha"
- "@types/node"
- "mocha"
- "ts-node"
- "tslint"
- "typescript"))))
- (replace 'build
- (lambda* (#:key inputs #:allow-other-keys)
- (let ((esbuild (search-input-file inputs "/bin/esbuild")))
- (invoke esbuild
- "--platform=node"
- "--outfile=lib/builder.js"
- "--bundle"
- "src/builder.ts")))))))
- (inputs
- (list node-binary-search-bootstrap node-debug-bootstrap))
- (native-inputs
- (list esbuild))
- (home-page "https://github.com/indutny/llparse-builder#readme")
- (properties '((hidden? . #t)))
- (synopsis "Graph builder for consumption by llparse")
- (description "This package builds graphs for consumption by llparse.")
- (license license:expat)))
-
(define-public llhttp-bootstrap
(package
(inherit llhttp)
--
2.45.1
From b240d0be9d922d1950917f551328f577963287a0 Mon Sep 17 00:00:00 2001
Message-ID: <b240d0be9d922d1950917f551328f577963287a0.1718694047.git.ashvithshetty10@gmail.com>
In-Reply-To: <28992bda8dae74e665bfc7b7c5b877a04afd31f4.1718694047.git.ashvithshetty10@gmail.com>
References: <28992bda8dae74e665bfc7b7c5b877a04afd31f4.1718694047.git.ashvithshetty10@gmail.com>
From: Ashvith Shetty <ashvithshetty10@gmail.com>
Date: Tue, 18 Jun 2024 10:56:37 +0530
Subject: [PATCH 5/8] gnu: Remove node-debug-bootstrap.
* gnu/packages/node.scm (node-debug-bootstrap): Delete variable.
Change-Id: I09a1da904c604c05ad99a9475b1465f62bcb534c
---
gnu/packages/node.scm | 42 ------------------------------------------
1 file changed, 42 deletions(-)
@@ -397,48 +397,6 @@ (define-public node-binary-search-bootstrap
(description "This package is a binary search function for Node.js.")
(license license:cc0)))
-(define-public node-debug-bootstrap
- (package
- (name "node-debug")
- (version "4.3.0")
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/visionmedia/debug.git")
- (commit version)))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "08g52r1d4yqcsfdfb7n5if33d4cghaq75gx5n9hj6m6fd8jfp2pi"))))
- (build-system node-build-system)
- (arguments
- `(#:node ,node-bootstrap
- #:tests? #f
- #:phases
- (modify-phases %standard-phases
- (add-after 'patch-dependencies 'delete-dependencies
- (lambda args
- (delete-dependencies `("brfs"
- "browserify"
- "coveralls"
- "istanbul"
- "karma"
- "karma-browserify"
- "karma-chrome-launcher"
- "karma-mocha"
- "mocha"
- "mocha-lcov-reporter"
- "xo")))))))
- (inputs (list node-ms-bootstrap))
- (home-page "https://github.com/visionmedia/debug#readme")
- (properties '((hidden? . #t)))
- (synopsis "Small debugging utility")
- (description "This package contains a tiny JavaScript debugging
-utility modelled after Node.js core's debugging technique. It works in
-Node.js and web browsers.")
- (license license:expat)))
-
(define-public llhttp-bootstrap
(package
(inherit llhttp)
--
2.45.1
From 2f0f201865550795fc16cd72983e333aa56d6557 Mon Sep 17 00:00:00 2001
Message-ID: <2f0f201865550795fc16cd72983e333aa56d6557.1718694047.git.ashvithshetty10@gmail.com>
In-Reply-To: <28992bda8dae74e665bfc7b7c5b877a04afd31f4.1718694047.git.ashvithshetty10@gmail.com>
References: <28992bda8dae74e665bfc7b7c5b877a04afd31f4.1718694047.git.ashvithshetty10@gmail.com>
From: Ashvith Shetty <ashvithshetty10@gmail.com>
Date: Tue, 18 Jun 2024 10:59:35 +0530
Subject: [PATCH 6/8] gnu: Remove node-binary-search-bootstrap.
* gnu/packages/node.scm (node-binary-search-bootstrap): Delete variable.
Change-Id: I10402c840ed794d0bfba17a4033454de8a06a170
---
gnu/packages/node.scm | 29 -----------------------------
1 file changed, 29 deletions(-)
@@ -368,35 +368,6 @@ (define-public node-ms-bootstrap
formats to milliseconds.")
(license license:expat)))
-(define-public node-binary-search-bootstrap
- (package
- (name "node-binary-search")
- (version "1.3.6")
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/darkskyapp/binary-search.git")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "1xr2msdc143cd3xwgq7n3rhzy7j8wrnaidxl0r6l6b6g3mpbpjig"))))
- (build-system node-build-system)
- (arguments
- `(#:node ,node-bootstrap
- #:tests? #f
- #:phases
- (modify-phases %standard-phases
- (add-after 'patch-dependencies 'delete-dependencies
- (lambda args
- (delete-dependencies `("chai" "mocha")))))))
- (home-page "https://github.com/darkskyapp/binary-search#readme")
- (properties '((hidden? . #t)))
- (synopsis "Tiny binary search function with comparators")
- (description "This package is a binary search function for Node.js.")
- (license license:cc0)))
-
(define-public llhttp-bootstrap
(package
(inherit llhttp)
--
2.45.1
From 2b85e5b54589ee39e645ea2a98a0d2452a6fb51d Mon Sep 17 00:00:00 2001
Message-ID: <2b85e5b54589ee39e645ea2a98a0d2452a6fb51d.1718694047.git.ashvithshetty10@gmail.com>
In-Reply-To: <28992bda8dae74e665bfc7b7c5b877a04afd31f4.1718694047.git.ashvithshetty10@gmail.com>
References: <28992bda8dae74e665bfc7b7c5b877a04afd31f4.1718694047.git.ashvithshetty10@gmail.com>
From: Ashvith Shetty <ashvithshetty10@gmail.com>
Date: Tue, 18 Jun 2024 11:03:07 +0530
Subject: [PATCH 7/8] gnu: Remove node-ms-bootstrap.
* gnu/packages/node.scm (node-ms-bootstrap): Delete variable.
Change-Id: I8700591f516819fe848b77e936c89057708a4225
---
gnu/packages/node.scm | 34 ----------------------------------
1 file changed, 34 deletions(-)
@@ -334,40 +334,6 @@ (define-public node
(define-public node-bootstrap
(hidden-package node))
-(define-public node-ms-bootstrap
- (package
- (name "node-ms")
- (version "2.1.2")
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/vercel/ms.git")
- (commit version)))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "1pjxzbi4j8pinlsc7yxvfrh0b47kb2dc4lfc2rjq4wx5bdwl33fj"))))
- (build-system node-build-system)
- (arguments
- `(#:node ,node-bootstrap
- #:tests? #f
- #:phases
- (modify-phases %standard-phases
- (add-after 'patch-dependencies 'delete-dependencies
- (lambda args
- (delete-dependencies '("eslint"
- "expect.js"
- "husky"
- "lint-staged"
- "mocha")))))))
- (home-page "https://github.com/zeit/ms#readme")
- (properties '((hidden? . #t)))
- (synopsis "Tiny millisecond conversion utility")
- (description "Use this package to easily convert various time
-formats to milliseconds.")
- (license license:expat)))
-
(define-public llhttp-bootstrap
(package
(inherit llhttp)
--
2.45.1
From c94d790c6c75ae87d7c79068cbf5f75c8ae49b02 Mon Sep 17 00:00:00 2001
Message-ID: <c94d790c6c75ae87d7c79068cbf5f75c8ae49b02.1718694047.git.ashvithshetty10@gmail.com>
In-Reply-To: <28992bda8dae74e665bfc7b7c5b877a04afd31f4.1718694047.git.ashvithshetty10@gmail.com>
References: <28992bda8dae74e665bfc7b7c5b877a04afd31f4.1718694047.git.ashvithshetty10@gmail.com>
From: Ashvith Shetty <ashvithshetty10@gmail.com>
Date: Tue, 18 Jun 2024 11:19:28 +0530
Subject: [PATCH 8/8] gnu: llhttp-bootstrap: Move to web and rename to
llhttp-node-lts.
* gnu/packages/node.scm (llhttp-bootstrap): Move
from here ...
* gnu/packages/web.scm: ... to here and rename to llhttp-node-lts.
Change-Id: Iaec111d69b157de924d7809f9d11d6878a9860b7
---
gnu/packages/node.scm | 8 +-------
gnu/packages/web.scm | 6 ++++++
2 files changed, 7 insertions(+), 7 deletions(-)
@@ -334,12 +334,6 @@ (define-public node
(define-public node-bootstrap
(hidden-package node))
-(define-public llhttp-bootstrap
- (package
- (inherit llhttp)
- (version "6.1.0")
- (properties '((hidden? . #t)))))
-
(define-public node-lts
(package
(inherit node)
@@ -537,7 +531,7 @@ (define-public node-lts
c-ares-for-node
icu4c
libuv
- llhttp-bootstrap
+ llhttp-node-lts
brotli
`(,nghttp2 "lib")
openssl
@@ -6937,6 +6937,12 @@ (define-public llhttp
efficient where possible.")
(license license:expat)))
+(define-public llhttp-node-lts
+ (package
+ (inherit llhttp)
+ (version "6.1.0")
+ (properties '((hidden? . #t)))))
+
(define-public python-httpretty
(package
(name "python-httpretty")