diff mbox series

[bug#56729,RFC,v3,04/32] gnu: python-gmpy2: Move to (gnu packages multiprecision).

Message ID 287d605d4a50255e65ae21bcaac3ad1a8b9b73c9.1685391447.git.guix@ikherbers.com
State New
Headers show
Series None | expand

Commit Message

vicvbcun May 29, 2023, 8:38 p.m. UTC
* gnu/packages/sagemath.scm (python-gmpy2): Move from here ...
* gnu/packages/multiprecision.scm (python-gmpy2): ... to here.
---

Notes:
    Prevent cycle (gnu packages sagemath) -> (gnu packages multiprecision) -> (gnu packages sagemath)

 gnu/packages/multiprecision.scm | 28 +++++++++++++++++++++++++++-
 gnu/packages/sagemath.scm       | 25 -------------------------
 2 files changed, 27 insertions(+), 26 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/multiprecision.scm b/gnu/packages/multiprecision.scm
index 6ba08be3a3..a955a8cae2 100644
--- a/gnu/packages/multiprecision.scm
+++ b/gnu/packages/multiprecision.scm
@@ -30,6 +30,7 @@  (define-module (gnu packages multiprecision)
   #:use-module (gnu packages)
   #:use-module (gnu packages autotools)
   #:use-module (gnu packages bison)
+  #:use-module (gnu packages compression)
   #:use-module (gnu packages flex)
   #:use-module (gnu packages m4)
   #:use-module (gnu packages gcc)
@@ -39,7 +40,8 @@  (define-module (gnu packages multiprecision)
   #:use-module (guix git-download)
   #:use-module (guix packages)
   #:use-module (guix utils)
-  #:use-module (guix build-system gnu))
+  #:use-module (guix build-system gnu)
+  #:use-module (guix build-system python))
 
 (define-public gmp
   (package
@@ -116,6 +118,30 @@  (define-public gmp-6.0
               (patches (search-patches "gmp-arm-asm-nothumb.patch"
                                        "gmp-faulty-test.patch"))))))
 
+(define-public python-gmpy2
+  (package
+    (name "python-gmpy2")
+    (version "2.1.2")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "gmpy2" version))
+       (sha256
+        (base32
+         "1lc29g3s4z5f1qbsc2x9i9sf6wrpni9pwiwmb1wwx3hjr85i8xfs"))))
+    (build-system python-build-system)
+    (native-inputs
+     (list unzip))
+    (inputs
+     (list gmp mpfr mpc))
+    (home-page "https://github.com/aleaxit/gmpy")
+    (synopsis
+     "GMP/MPIR, MPFR, and MPC interface to Python 2.6+ and 3.x")
+    (description
+     "This package provides a Python interface to the GNU multiprecision
+libraries GMO, MPFR and MPC.")
+    (license lgpl3+)))
+
 (define-public mpfr
   (package
    (name "mpfr")
diff --git a/gnu/packages/sagemath.scm b/gnu/packages/sagemath.scm
index 3138006e77..04bb17dc9d 100644
--- a/gnu/packages/sagemath.scm
+++ b/gnu/packages/sagemath.scm
@@ -33,7 +33,6 @@  (define-module (gnu packages sagemath)
   #:use-module (gnu packages autotools)
   #:use-module (gnu packages bdw-gc)
   #:use-module (gnu packages boost)
-  #:use-module (gnu packages compression)
   #:use-module (gnu packages image)
   #:use-module (gnu packages lisp)
   #:use-module (gnu packages multiprecision)
@@ -70,30 +69,6 @@  (define-public python-cypari2
 but it can be used independently.")
     (license license:gpl2+)))
 
-(define-public python-gmpy2
-  (package
-    (name "python-gmpy2")
-    (version "2.1.2")
-    (source
-     (origin
-       (method url-fetch)
-       (uri (pypi-uri "gmpy2" version))
-       (sha256
-        (base32
-         "1lc29g3s4z5f1qbsc2x9i9sf6wrpni9pwiwmb1wwx3hjr85i8xfs"))))
-    (build-system python-build-system)
-    (native-inputs
-     (list unzip))
-    (inputs
-     (list gmp mpfr mpc))
-    (home-page "https://github.com/aleaxit/gmpy")
-    (synopsis
-     "GMP/MPIR, MPFR, and MPC interface to Python 2.6+ and 3.x")
-    (description
-     "This package provides a Python interface to the GNU multiprecision
-libraries GMO, MPFR and MPC.")
-    (license license:lgpl3+)))
-
 (define-public cliquer
   (package
     (name "cliquer")