diff mbox series

[bug#71608,2/2] gnu: Add python-wtforms-sqlalchemy

Message ID 284bbf3b68f03834e7bee0c9ee755ac71bf043a7.1718606041.git.ben@sturm.com.au
State New
Headers show
Series Update python-wtforms (and add split out python-wtforms-sqlalchemy) | expand

Commit Message

Ben Sturmfels June 17, 2024, 6:49 a.m. UTC
* gnu/packages/python-web.scm (python-wtforms-sqlalchemy): New variable

Change-Id: Ie94c07d055ec42f08db3a18894e7f6184006764f
---
 gnu/packages/python-web.scm | 22 ++++++++++++++++++++++
 1 file changed, 22 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index fae4b8bf0f..1363e6ccdf 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -5288,6 +5288,28 @@  (define-public python-wtforms
 available in Django, but is a standalone package.")
     (license license:bsd-3)))
 
+(define-public python-wtforms-sqlalchemy
+  (package
+    (name "python-wtforms-sqlalchemy")
+    (version "0.4.1")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "WTForms-SQLAlchemy" version))
+       (sha256
+        (base32 "1nx4x0ifanlbrzh3f9ns8ihnchlkzf54ilvqmgcgcz2j72vm43rp"))))
+    (build-system pyproject-build-system)
+    (native-inputs (list python-pytest))
+    (propagated-inputs (list python-sqlalchemy python-wtforms))
+    (home-page "https://github.com/wtforms/wtforms-sqlalchemy/")
+    (synopsis "SQLAlchemy tools for WTForms")
+    (description
+     "WTForms-SQLAlchemy is a fork of the @code{wtforms.ext.sqlalchemy}
+package from WTForms.  The package has been renamed to
+@code{wtforms_sqlalchemy} but otherwise should function the same as
+@code{wtforms.ext.sqlalchemy} did.")
+    (license license:bsd-3)))
+
 (define-public python-paste
   (package
     (name "python-paste")