diff mbox series

[bug#67617] gnu: Add python-icegrams.

Message ID 283ec0dc3ea786a66c3e4eac20da222b79dc0902.1701658991.git.spencer@nursiapress.com
State New
Headers show
Series [bug#67617] gnu: Add python-icegrams. | expand

Commit Message

Spencer King Dec. 4, 2023, 3:03 a.m. UTC
* gnu/packages/python-xyz.scm (python-icegrams): New variable.

Change-Id: Ia0044304f8b2002a5362813448a6172c2f3eef5b
---
 gnu/packages/python-xyz.scm | 23 +++++++++++++++++++++++
 1 file changed, 23 insertions(+)


base-commit: 6e2dd51df5f3f51e9056dd4f2e1b036195ab3caa

Comments

Ludovic Courtès Dec. 23, 2023, 10:17 a.m. UTC | #1
Spencer King <spencer@nursiapress.com> skribis:

> * gnu/packages/python-xyz.scm (python-icegrams): New variable.
>
> Change-Id: Ia0044304f8b2002a5362813448a6172c2f3eef5b

Applied, thanks!
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index f87e6fc3f7..c2f3475362 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -34242,6 +34242,29 @@  (define-public python-islenska
 forms, and about 300,000 distinct lemmas.")
     (license license:expat)))
 
+(define-public python-icegrams
+  (package
+    (name "python-icegrams")
+    (version "1.1.2")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "icegrams" version))
+       (sha256
+        (base32 "1ajcjngvr4rlgb0q6p6vjz2sncwhvq3msjy6qaiz5g37vgvw2ij8"))))
+    (build-system pyproject-build-system)
+    (propagated-inputs (list python-cffi))
+    (home-page "https://github.com/mideind/Icegrams")
+    (synopsis "Trigram statistics for Icelandic")
+    (description
+     "Icegrams is a Python package that encapsulates a large trigram
+library for Icelandic.  You can use Icegrams to obtain probabilities (relative
+frequencies) of over a million different unigrams (single words or tokens), or of
+bigrams (pairs of two words or tokens), or of trigrams.  Icegrams is useful for
+instance in spelling correction, predictive typing, to help disabled people
+write text fast, and for various text generation, statistics, and modeling tasks.")
+    (license license:expat)))
+
 (define-public python-zeroc-ice-3.6
   (package
     (inherit python-zeroc-ice)