diff mbox series

[bug#71640,2/6] gnu: Add python-requests 2.31.0.

Message ID 2835a9879fa8be8172b2b4d86c5d5395ec80dd83.1718763195.git.leo@famulari.name
State New
Headers show
Series [bug#71640,1/6] gnu: yt-dlp: Don't inherit from youtube-dl. | expand

Commit Message

Leo Famulari June 19, 2024, 2:13 a.m. UTC
This is the minimum required version in recent versions of yt-dlp.

* gnu/packages/python-web.scm (python-requests-next): New variable.

Change-Id: I825cb928297cddc2fbbca1ce5acdbf6cff276bbc
---
 gnu/packages/python-web.scm | 26 ++++++++++++++++++++++++++
 1 file changed, 26 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 1363e6ccdf..2686cb283f 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -3603,6 +3603,32 @@  (define-public python-requests
 than Python’s urllib2 library.")
     (license license:asl2.0)))
 
+(define-public python-requests-next
+  (package
+    (name "python-requests")
+    (version "2.31.0")
+    (source (origin
+             (method url-fetch)
+             (uri (pypi-uri "requests" version))
+             (sha256
+              (base32
+               "1qfidaynsrci4wymrw3srz8v1zy7xxpcna8sxpm91mwqixsmlb4l"))))
+    (build-system python-build-system)
+    (propagated-inputs
+     (list python-certifi
+           python-charset-normalizer
+           python-idna
+           python-urllib3))
+    (arguments
+     ;; FIXME: Some tests require network access.
+     '(#:tests? #f))
+    (home-page "http://python-requests.org/")
+    (synopsis "Python HTTP library")
+    (description
+     "Requests is a Python HTTP client library.  It aims to be easier to use
+than Python’s urllib2 library.")
+    (license license:asl2.0)))
+
 (define-public python-requests-kerberos
   (package
     (name "python-requests-kerberos")