diff mbox series

[bug#69504,v2] gnu: Add wbg.

Message ID 280add0be03067b816309257ba7385f1e9f02a41.1716610650.git.i@dan.games
State New
Headers show
Series [bug#69504,v2] gnu: Add wbg. | expand

Commit Message

dan May 25, 2024, 4:17 a.m. UTC
* gnu/packages/wm.scm (wbg): New variable.

Change-Id: Ib20af5fee37ab258224ead6caf35af3b9c78e802
---
 gnu/packages/wm.scm | 32 ++++++++++++++++++++++++++++++++
 1 file changed, 32 insertions(+)


base-commit: c5e63e19ac672f9e63fc8ee98fa9a16f978ce19c

Comments

Zheng Junjie June 22, 2024, 1:44 p.m. UTC | #1
dan <i@dan.games> writes:

> * gnu/packages/wm.scm (wbg): New variable.
>
> Change-Id: Ib20af5fee37ab258224ead6caf35af3b9c78e802
> ---
>  gnu/packages/wm.scm | 32 ++++++++++++++++++++++++++++++++
>  1 file changed, 32 insertions(+)
>
> diff --git a/gnu/packages/wm.scm b/gnu/packages/wm.scm
> index 8f74076cfd..c5194de1fc 100644
> --- a/gnu/packages/wm.scm
> +++ b/gnu/packages/wm.scm
> @@ -72,6 +72,7 @@
>  ;;; Copyright © 2024 Erik Eduardo Alonso Hernández <erik@erikeduardo.xyz>
>  ;;; Copyright © 2024 James Smith <jsubuntuxp@disroot.org>
>  ;;; Copyright © 2024 bigbug <bigbookofbug@proton.me>
> +;;; Copyright © 2024 dan <i@dan.games>
>  ;;;
>  ;;; This file is part of GNU Guix.
>  ;;;
> @@ -3905,3 +3906,34 @@ (define-public yambar-wayland
>  for short) for X11 and Wayland, that goes to great lengths to be both CPU and
>  battery efficient---polling is only done when absolutely necessary.")
>      (license license:expat)))
> +
> +(define-public wbg
> +  ;; This commit fixes a build error: https://codeberg.org/dnkl/wbg/issues/11
> +  (let ((commit "dd36cce8c47bb0e17a789cf2bd95a51e29b59e78")
> +        (revision "0"))
> +    (package
> +      (name "wbg")
> +      (version (git-version "1.2.0" revision commit))
> +      (source
> +       (origin
> +         (method git-fetch)
> +         (uri (git-reference
> +               (url "https://codeberg.org/dnkl/wbg")
> +               (commit commit)))
> +         (sha256
> +          (base32 "0nsb8w3myprhnwr59i6g4nwkc8fx67d40l70svjmwfmhpqy6zc18"))))
> +      (build-system meson-build-system)
> +      (arguments
> +       (list
> +        #:build-type "release"
> +        #:configure-flags #~(list "-Dpng=enabled"
> +                                  "-Djpeg=enabled"
> +                                  "-Dwebp=enabled")))
> +      (native-inputs (list pkg-config tllist wayland-protocols))
> +      (inputs (list libjpeg-turbo libpng libwebp pixman wayland))
> +      (home-page "https://codeberg.org/dnkl/wbg")
> +      (synopsis "Wallpaper application for Wayland compositors")
> +      (description
> +       "wbg is a super simple wallpaper application for Wayland compositors
> +implementing the layer-shell protocol.")
> +      (license license:expat))))
>
> base-commit: c5e63e19ac672f9e63fc8ee98fa9a16f978ce19c

move before wsbg, and add (file-name (git-file-name name version)).

push, see https://git.savannah.gnu.org/cgit/guix.git/commit/?id=8ed430586466d8ada91d6d252bfafe4b244e731d
diff mbox series

Patch

diff --git a/gnu/packages/wm.scm b/gnu/packages/wm.scm
index 8f74076cfd..c5194de1fc 100644
--- a/gnu/packages/wm.scm
+++ b/gnu/packages/wm.scm
@@ -72,6 +72,7 @@ 
 ;;; Copyright © 2024 Erik Eduardo Alonso Hernández <erik@erikeduardo.xyz>
 ;;; Copyright © 2024 James Smith <jsubuntuxp@disroot.org>
 ;;; Copyright © 2024 bigbug <bigbookofbug@proton.me>
+;;; Copyright © 2024 dan <i@dan.games>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -3905,3 +3906,34 @@  (define-public yambar-wayland
 for short) for X11 and Wayland, that goes to great lengths to be both CPU and
 battery efficient---polling is only done when absolutely necessary.")
     (license license:expat)))
+
+(define-public wbg
+  ;; This commit fixes a build error: https://codeberg.org/dnkl/wbg/issues/11
+  (let ((commit "dd36cce8c47bb0e17a789cf2bd95a51e29b59e78")
+        (revision "0"))
+    (package
+      (name "wbg")
+      (version (git-version "1.2.0" revision commit))
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+               (url "https://codeberg.org/dnkl/wbg")
+               (commit commit)))
+         (sha256
+          (base32 "0nsb8w3myprhnwr59i6g4nwkc8fx67d40l70svjmwfmhpqy6zc18"))))
+      (build-system meson-build-system)
+      (arguments
+       (list
+        #:build-type "release"
+        #:configure-flags #~(list "-Dpng=enabled"
+                                  "-Djpeg=enabled"
+                                  "-Dwebp=enabled")))
+      (native-inputs (list pkg-config tllist wayland-protocols))
+      (inputs (list libjpeg-turbo libpng libwebp pixman wayland))
+      (home-page "https://codeberg.org/dnkl/wbg")
+      (synopsis "Wallpaper application for Wayland compositors")
+      (description
+       "wbg is a super simple wallpaper application for Wayland compositors
+implementing the layer-shell protocol.")
+      (license license:expat))))