diff mbox series

[bug#68155] gnu: Add qcheckers.

Message ID 2807f423d267a29b7805549b4f51653d6b3dc659.1703964350.git.w@wmeyer.eu
State New
Headers show
Series [bug#68155] gnu: Add qcheckers. | expand

Commit Message

Wilko Meyer Dec. 30, 2023, 7:25 p.m. UTC
* gnu/packages/games.scm (qcheckers): New variable.

Change-Id: I399ac6aa0c268a8fcf68aabe716fe2d2d5e42605
---
 gnu/packages/games.scm | 31 +++++++++++++++++++++++++++++++
 1 file changed, 31 insertions(+)


base-commit: f24b14767d362a84e6469682b4fe303b50f4b589

Comments

Guillaume Le Vaillant Jan. 6, 2024, 3 p.m. UTC | #1
Patch applied as 9891dd881489be65980f326d87ca580c0001c778.
Thanks.
diff mbox series

Patch

diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 8313c027545..1e203af9d1d 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -79,6 +79,7 @@ 
 ;;; Copyright © 2023 Florian Pelz <pelzflorian@pelzflorian.de>
 ;;; Copyright © 2023 Ivana Drazovic <iv.dra@hotmail.com>
 ;;; Copyright © 2023 gemmaro <gemmaro.dev@gmail.com>
+;;; Copyright © 2023 Wilko Meyer <w@wmeyer.eu>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -10115,6 +10116,36 @@  (define-public q5go
    (home-page "https://github.com/bernds/q5Go")
    (license license:gpl2+)))
 
+(define-public qcheckers
+  (package
+    (name "qcheckers")
+    (version "0.9.0")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/portnov/qcheckers")
+             (commit version)))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "05wzql6abzdf6l0vdzki4rfy2zn31mcplh1wkw3ddk8w81pvaymw"))))
+    (build-system qt-build-system)
+    (arguments
+     (list
+      #:tests? #f
+      #:phases
+      #~(modify-phases %standard-phases
+          (replace 'configure
+            (lambda _
+              (invoke "qmake"
+                      (string-append "PREFIX=" #$output)))))))
+    (inputs (list qtbase-5 qtsvg-5))
+    (home-page "https://portnov.github.io/qcheckers/")
+    (synopsis "Qt-based checkers boardgame")
+    (description "QCheckers, formely known as KCheckers, is a is a Qt version
+of the classic boardgame checkers (also known as draughts).")
+    (license license:gpl2)))
+
 (define-public xmoto
   (package
     (name "xmoto")