diff mbox series

[bug#38689] Add VL1 emulator, regrader and fogpad

Message ID 27c62f6ce6c37bcecc891cebba898370149abd30.camel@zrythm.org
State Accepted
Headers show
Series [bug#38689] Add VL1 emulator, regrader and fogpad | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job

Commit Message

Alexandros Theodotou Feb. 25, 2020, 2:55 p.m. UTC
Hi,

I've fixed some indentation issues with the patch and I also made a
patch series including fogpad and regrader since I made them inherit
this. The build procedure is the same because they use the same
framework and are by the same upstream.

Please close this https://debbugs.gnu.org/db/39/39213.html as well
because it is confusing to have separate issues.

Thanks,
Alex

Comments

Alexandros Theodotou Feb. 26, 2020, 10:07 p.m. UTC | #1
Hi,

Just some additional info that might help with reviewing.

To test that the plugins work, you can run the following if you already
have JACK running:
LV2_PATH=/gnu/store/pi5csq02yihgdg49g3vadwk3l9n7ax4h-vl1-emulator-
1.1.0.0/lib/lv2 jalv.gtk3 https://polyvalens.com/plugins/VL1
LV2_PATH=/gnu/store/zh26l9p7j08zjnhnpan6345j9nxvaj8j-regrader-
1.0.0/lib/lv2 jalv.gtk3 https://github.com/linuxmao-org/regrader
LV2_PATH=/gnu/store/8n2xi5hzskvajynx0fikn2cgdqaa22fq-fogpad-
1.0.0/lib/lv2 jalv.gtk3 https://github.com/linuxmao-org/fogpad

If you don't have JACK running (most likely case), you can run a dummy
server temporarily with `jackd -ddummy`.

Thanks,
Alex
diff mbox series

Patch

From 77bf5b5a618d4e835de81fb2af58c28c60bf4605 Mon Sep 17 00:00:00 2001
From: Alexandros Theodotou <alex@zrythm.org>
Date: Tue, 25 Feb 2020 14:46:08 +0000
Subject: [PATCH 1/3] gnu: Add vl1-emulator.

* gnu/packages/music.scm (vl1-emulator): New variable.
---
 gnu/packages/music.scm | 42 ++++++++++++++++++++++++++++++++++++++++++
 1 file changed, 42 insertions(+)

diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index 16e69840df..954e82dc35 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -5189,3 +5189,45 @@  featureful and easy to use.  It offers unlimited automation options, LV2
 plugin support, JACK support and chord assistance.")
    (home-page "https://www.zrythm.org")
    (license license:agpl3+)))
+
+(define-public vl1-emulator
+  (package
+    (name "vl1-emulator")
+    (version "1.1.0.0")
+    (source
+      (origin
+        (method git-fetch)
+        (uri (git-reference
+               (url "https://github.com/linuxmao-org/VL1-emulator.git")
+               (commit (string-append "v" version))
+               ;; bundles a specific commit of the DISTRHO plugin framework
+               (recursive? #t)))
+        (file-name (git-file-name name version))
+        (sha256
+         (base32
+          "1npc86vqma8gk1hawa0lii0r2xmnv846plyl1ci3bdswyrdk5chm"))))
+    (build-system gnu-build-system)
+    (arguments
+     `(#:tests? #f ; no check target
+       #:make-flags
+       (list (string-append "PREFIX=" (assoc-ref %outputs "out"))
+             "CC=gcc")
+       #:phases
+       (modify-phases %standard-phases
+         (delete 'configure)))) ; no configure target
+    (inputs
+     `(("cairo" ,cairo)
+       ("jack" ,jack-1)
+       ("libx11" ,libx11)
+       ("mesa" ,mesa)))
+    (native-inputs
+     `(("lv2" ,lv2)
+       ("pkg-config" ,pkg-config)))
+    (home-page "https://github.com/linuxmao-org/VL1-emulator")
+    (synopsis "Emulator of Casio VL-Tone VL1")
+    (description
+     "The VL1-Emulator is an emulator of Casio VL-Tone VL1, based on source
+code by PolyValens, offered as a VST plugin, an LV2 plugin and a standalone
+JACK application.")
+    ;; Expat or CC0
+    (license (list license:expat license:cc0))))
-- 
2.25.1