* gnu/packages/crates-io.scm (rust-jmalloc-ctl-0.4): Order.
Change-Id: Ic669a024b33402907755f46bbd3e9292fae22dc0
---
gnu/packages/crates-io.scm | 66 +++++++++++++++++++-------------------
1 file changed, 33 insertions(+), 33 deletions(-)
@@ -87789,6 +87789,39 @@ (define-public rust-thrift-0.13
("rust-ordered-float" ,rust-ordered-float-1)
("rust-threadpool" ,rust-threadpool-1))))))
+(define-public rust-tikv-jemalloc-ctl-0.4
+ (package
+ (name "rust-tikv-jemalloc-ctl")
+ (version "0.4.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "tikv-jemalloc-ctl" version))
+ (file-name
+ (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1pqs08dgnnrgbib8syldxmm8cjgyz80scs9i8jgn6mw86gj8137j"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:skip-build? #t
+ #:cargo-inputs
+ (("rust-libc" ,rust-libc-0.2)
+ ("rust-paste" ,rust-paste-0.1)
+ ("rust-tikv-jemalloc-sys"
+ ,rust-tikv-jemalloc-sys-0.4))
+ #:cargo-development-inputs
+ (("rust-tikv-jemallocator"
+ ,rust-tikv-jemallocator-0.4))))
+ (home-page
+ "https://github.com/tikv/jemallocator")
+ (synopsis
+ "Safe wrapper over jemalloc's control and introspection APIs")
+ (description
+ "This package provides a safe wrapper over jemalloc's control and
+introspection APIs.")
+ (license (list license:expat license:asl2.0))))
+
(define-public rust-tikv-jemalloc-sys-0.6
(package
(name "rust-tikv-jemalloc-sys")
@@ -87898,39 +87931,6 @@ (define-public rust-tikv-jemallocator-0.4
(("rust-libc" ,rust-libc-0.2)
("rust-tikv-jemalloc-sys" ,rust-tikv-jemalloc-sys-0.4))))))
-(define-public rust-tikv-jemalloc-ctl-0.4
- (package
- (name "rust-tikv-jemalloc-ctl")
- (version "0.4.1")
- (source
- (origin
- (method url-fetch)
- (uri (crate-uri "tikv-jemalloc-ctl" version))
- (file-name
- (string-append name "-" version ".tar.gz"))
- (sha256
- (base32
- "1pqs08dgnnrgbib8syldxmm8cjgyz80scs9i8jgn6mw86gj8137j"))))
- (build-system cargo-build-system)
- (arguments
- `(#:skip-build? #t
- #:cargo-inputs
- (("rust-libc" ,rust-libc-0.2)
- ("rust-paste" ,rust-paste-0.1)
- ("rust-tikv-jemalloc-sys"
- ,rust-tikv-jemalloc-sys-0.4))
- #:cargo-development-inputs
- (("rust-tikv-jemallocator"
- ,rust-tikv-jemallocator-0.4))))
- (home-page
- "https://github.com/tikv/jemallocator")
- (synopsis
- "Safe wrapper over jemalloc's control and introspection APIs")
- (description
- "This package provides a safe wrapper over jemalloc's control and
-introspection APIs.")
- (license (list license:expat license:asl2.0))))
-
(define-public rust-time-0.3
(package
(name "rust-time")