[bug#57419] gnu: add python-grid5000
Commit Message
From: msimonin <matthieu.simonin@inria.fr>
---
gnu/packages/python-web.scm | 25 +++++++++++++++++++++++++
1 file changed, 25 insertions(+)
base-commit: 6beadc82df204f315d06ea35f2e232bb32f8e440
Comments
matthieu.simonin@inria.fr skriver:
> Thanks Marius for the review,
>
> I'm sending the update.
> There are no suitable tests here, and I changed the licence to GPLv3
> everywhere.
>
> Let me know if anything else is needed.
Thanks! I filled in the commit message (noting the new variable in
python-web.scm), and also added a copyright line for you, hope that was
okay.
Pushed in c19a432652f2fb544eaf918fe287aa898748d76c.
@@ -7786,3 +7786,28 @@ (define-public python-whatthepatch
(description
"This package provides a library to parse and apply patches.")
(license license:expat)))
+
+(define-public python-grid5000
+ (package
+ (name "python-grid5000")
+ (version "1.2.3")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://gitlab.inria.fr/msimonin/python-grid5000")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ "097pm8b68ihk29xz9zv29b1x0bhgjb4lfj8zxk2grbsh7wr9dipg")))
+ (build-system python-build-system)
+ (native-inputs (list python-wheel))
+ (propagated-inputs (list python-requests python-ipython python-pyyaml))
+ (arguments
+ (list #:tests? #f)) ; No tests.
+ (home-page "https://pypi.org/project/python-grid5000/")
+ (synopsis "Grid5000 python client")
+ (description
+ "python-grid5000 is a python package wrapping the Grid5000 REST API.
+ You can use it as a library in your python project or you can
+ explore the Grid5000 resources interactively using the embedded shell.")
+ (license license:gpl3+)))