[bug#76537,rust-team,1/8] gnu: Add rust-dirs-6.
Commit Message
* gnu/packages/crates-io.scm (rust-dirs-6): New variable.
Change-Id: I86be1720117f854b626e3b0c7868be44f4c4151e
---
gnu/packages/crates-io.scm | 25 +++++++++++++++++++++++++
1 file changed, 25 insertions(+)
@@ -21167,6 +21167,31 @@ (define-public rust-directories-next-2
other data.")
(license (list license:expat license:asl2.0))))
+(define-public rust-dirs-6
+ (package
+ (name "rust-dirs")
+ (version "6.0.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "dirs" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "0knfikii29761g22pwfrb8d0nqpbgw77sni9h2224haisyaams63"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:cargo-inputs (("rust-dirs-sys" ,rust-dirs-sys-0.5))))
+ (home-page "https://github.com/soc/dirs-rs")
+ (synopsis
+ "tiny low-level library that provides platform-specific standard locations of directories for config, cache and other data on Linux, Windows, macOS and Redox by leveraging the mechanisms defined by the XDG base/user directory specifications on Linux, the Known Folder API on Windows, and the Standard Directory guidelines on macOS.")
+ (description
+ "This package provides a tiny low-level library that provides platform-specific
+standard locations of directories for config, cache and other data on Linux,
+Windows, @code{macOS} and Redox by leveraging the mechanisms defined by the XDG
+base/user directory specifications on Linux, the Known Folder API on Windows,
+and the Standard Directory guidelines on @code{macOS}.")
+ (license (list license:expat license:asl2.0))))
+
(define-public rust-dirs-5
(package
(name "rust-dirs")