diff mbox series

[bug#43613] compiling 1.1.0 from sources on linux with guile 3

Message ID 27781955-6d6c-df8c-b648-1db140775993@gmail.com
State Accepted
Headers show
Series [bug#43613] compiling 1.1.0 from sources on linux with guile 3 | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job

Commit Message

Yury Tarasievich Sept. 25, 2020, 9:02 a.m. UTC
Hello,

Had an issue with compiling 1.1.0 from source on
linux (64-bit slackware, almost current) with
guile 3.0.4.

First thing, it couldn't find guild with the
default configure template. I had to add a
kludge (configure.ac.diff, attached).

Then, it wouldn't compile some files in guix/
subdir. The diagnostics went like this in each case:

WARNING: (guix swh): `define-json-mapping'
imported from both (guix json) and (json)
WARNING: (guix swh): `define-json-mapping'
imported from both (guix json) and (json)
ice-9/eval.scm:293:34: error:
define-json-mapping: unbound variable
hint: Did you forget `(use-modules (json record))'?

I took the compiler's suggestion and added
'(use-modules (json record))'. Have no idea how
that works.
I'm attaching the patch for that
compilation_define-json-mapping.diff.

Hope that helps.

-Yury

Comments

Simon Tournier Oct. 28, 2020, 6:44 p.m. UTC | #1
Dear,

On Fri, 25 Sep 2020 at 12:02, Yury Tarasievich <yury.tarasievich@gmail.com> wrote:

> Had an issue with compiling 1.1.0 from source on
> linux (64-bit slackware, almost current) with
> guile 3.0.4.

What do you mean by “compiling 1.1.0 from source”?  Do you mean
compiling Guix from scratch (without any packages provided by “guix
environment guix”)?


All the best,
simon
Maxim Cournoyer July 16, 2021, 4:27 a.m. UTC | #2
Hi,

zimoun <zimon.toutoune@gmail.com> writes:

> Dear,
>
> On Fri, 25 Sep 2020 at 12:02, Yury Tarasievich <yury.tarasievich@gmail.com> wrote:
>
>> Had an issue with compiling 1.1.0 from source on
>> linux (64-bit slackware, almost current) with
>> guile 3.0.4.
>
> What do you mean by “compiling 1.1.0 from source”?  Do you mean
> compiling Guix from scratch (without any packages provided by “guix
> environment guix”)?

I'm closing this forgotten issue.

Thanks,

Maxim
diff mbox series

Patch

--- guix/import/crate.scm.prev	2020-03-24 17:44:45.000000000 +0300
+++ guix/import/crate.scm	2020-09-24 23:16:07.076901808 +0300
@@ -52,6 +52,7 @@ 
 ;; Crates.  A crate is essentially a "package".  It can have several
 ;; "versions", each of which has its own set of dependencies, license,
 ;; etc.--see <crate-version> below.
+(use-modules (json record))
 (define-json-mapping <crate> make-crate crate?
   json->crate
   (name          crate-name)                      ;string
--- guix/swh.scm.prev	2020-03-10 22:19:30.000000000 +0300
+++ guix/swh.scm	2020-09-24 23:11:45.910912646 +0300
@@ -251,6 +251,7 @@ 
        docstring
        (call (swh-url components ...) json->value)))))
 
+(use-modules (json record))
 ;; <https://archive.softwareheritage.org/api/1/origin/https://github.com/guix-mirror/guix/get>
 (define-json-mapping <origin> make-origin origin?
   json->origin
--- guix/cve.scm.prev	2019-10-23 17:40:23.000000000 +0300
+++ guix/cve.scm	2020-09-24 23:12:16.596911372 +0300
@@ -70,6 +70,7 @@ 
 (define (string->date* str)
   (string->date str "~Y-~m-~dT~H:~M~z"))
 
+(use-modules (json record))
 (define-json-mapping <cve-item> cve-item cve-item?
   json->cve-item
   (cve            cve-item-cve "cve" json->cve)   ;<cve>
--- guix/ci.scm.prev	2020-03-31 15:55:42.000000000 +0300
+++ guix/ci.scm	2020-09-24 23:08:53.074919818 +0300
@@ -52,6 +52,8 @@ 
 ;;;
 ;;; Code:
 
+(use-modules (json record))
+
 (define-json-mapping <build> make-build build?
   json->build
   (id          build-id "id")                     ;integer