diff mbox series

[bug#73184,4/5] gnu: Add go-github-com-workiva-go-datastructures.

Message ID 273c37819556c45cc9b9ce2b68e326e39031ed53.1726082409.git.poptsov.artyom@gmail.com
State New
Headers show
Series Add some Golang libraries from the "awesome-go" list | expand

Commit Message

Artyom V. Poptsov Sept. 11, 2024, 7:23 p.m. UTC
* gnu/packages/golang-xyz.scm (go-github-com-workiva-go-datastructures): New variable.

Change-Id: I1523c7aeaed0910fbfbfe7fc96566684fdd2dab8
---
 gnu/packages/golang-xyz.scm | 51 +++++++++++++++++++++++++++++++++++++
 1 file changed, 51 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index eb04ff639b..7cad8c7e94 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -6789,6 +6789,57 @@  (define-public go-github-com-whyrusleeping-go-sysinfo
 @code{MemoryInfo}.")
     (license license:expat)))
 
+(define-public go-github-com-workiva-go-datastructures
+  (package
+    (name "go-github-com-workiva-go-datastructures")
+    (version "1.1.5")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/Workiva/go-datastructures")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "09k5zg0ma8z5bcfwk3viccaxzrrk5pyfhk5hkr9x34vgcnlk0jx7"))))
+    (build-system go-build-system)
+    (arguments
+     (list
+      #:import-path "github.com/Workiva/go-datastructures"))
+    (native-inputs (list go-github-com-stretchr-testify))
+    (propagated-inputs (list go-github-com-tinylib-msgp))
+    (home-page "https://github.com/Workiva/go-datastructures")
+    (synopsis "Collection of Go data structures")
+    (description
+     "@code{go-datastructures} is a collection of useful, performant, and thread-safe
+Go data structures.
+
+It includes:
+@itemize
+@item Augmented Tree
+@item Bitarray
+@item Futures
+@item Queue
+@item Fibonacci Heap
+@item Range Tree
+@item Set
+@item Threadsafe
+@item AVL Tree
+@item X-Fast Trie
+@item Y-Fast Trie
+@item Fast Integer Hashmap
+@item Skiplist
+@item Sort
+@item Numerics
+@item B+ Tree
+@item Immutable B Tree
+@item Ctrie
+@item Dtrie
+@item Persistent List
+@item Simple Graph
+@end itemize")
+    (license license:asl2.0)))
+
 (define-public go-github-com-xhit-go-str2duration-v2
   (package
     (name "go-github-com-xhit-go-str2duration-v2")