diff mbox series

[bug#47615,6/9] gnu: american-fuzzy-lop: Add support for powerpc-linux.

Message ID 26d9929a7c41d1c614dc2cc7fd082976c9f42b64.1617711307.git.efraim@flashner.co.il
State Accepted
Headers show
Series Add 32-bit powerpc support | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Efraim Flashner April 6, 2021, 12:32 p.m. UTC
* gnu/packages/debug.scm (american-fuzzy-lop): Add case for
powerpc-linux.
(qemu-for-american-fuzzy-lop): Same.
---
 gnu/packages/debug.scm | 2 ++
 1 file changed, 2 insertions(+)

Comments

Christopher Marusich April 14, 2021, 3:25 a.m. UTC | #1
Efraim Flashner <efraim@flashner.co.il> writes:

> * gnu/packages/debug.scm (american-fuzzy-lop): Add case for
> powerpc-linux.
> (qemu-for-american-fuzzy-lop): Same.
> ---
>  gnu/packages/debug.scm | 2 ++
>  1 file changed, 2 insertions(+)
>
> diff --git a/gnu/packages/debug.scm b/gnu/packages/debug.scm
> index 2913c348f3..1326ce6e16 100644
> --- a/gnu/packages/debug.scm
> +++ b/gnu/packages/debug.scm
> @@ -179,6 +179,7 @@ tools that process C/C++ code.")
>                     ("aarch64-linux"  "aarch64")
>                     ("armhf-linux"    "arm")
>                     ("mips64el-linux" "mips64el")
> +                   ("powerpc-linux"  "ppc")
>                     ;; Prevent errors when querying this package on unsupported
>                     ;; platforms, e.g. when running "guix package --search="
>                     (_                "UNSUPPORTED"))))
> @@ -254,6 +255,7 @@ down the road.")
>                     ("aarch64-linux"  "aarch64")
>                     ("armhf-linux"    "arm")
>                     ("mips64el-linux" "mips64el")
> +                   ("powerpc-linux"  "ppc")
>                     ;; Prevent errors when querying this package on unsupported
>                     ;; platforms, e.g. when running "guix package --search="
>                     (_                "UNSUPPORTED"))))

LGTM, I see it's in master already like you said.
diff mbox series

Patch

diff --git a/gnu/packages/debug.scm b/gnu/packages/debug.scm
index 2913c348f3..1326ce6e16 100644
--- a/gnu/packages/debug.scm
+++ b/gnu/packages/debug.scm
@@ -179,6 +179,7 @@  tools that process C/C++ code.")
                    ("aarch64-linux"  "aarch64")
                    ("armhf-linux"    "arm")
                    ("mips64el-linux" "mips64el")
+                   ("powerpc-linux"  "ppc")
                    ;; Prevent errors when querying this package on unsupported
                    ;; platforms, e.g. when running "guix package --search="
                    (_                "UNSUPPORTED"))))
@@ -254,6 +255,7 @@  down the road.")
                    ("aarch64-linux"  "aarch64")
                    ("armhf-linux"    "arm")
                    ("mips64el-linux" "mips64el")
+                   ("powerpc-linux"  "ppc")
                    ;; Prevent errors when querying this package on unsupported
                    ;; platforms, e.g. when running "guix package --search="
                    (_                "UNSUPPORTED"))))