diff mbox series

[bug#49067] gnu: Add font-overpass.

Message ID 26bf8963ceefcf4a546447d9571d007ffc4dbe82.1623887878.git.iskarian@mgsn.dev
State Accepted
Headers show
Series [bug#49067] gnu: Add font-overpass. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Sarah Morgensen June 17, 2021, 12:05 a.m. UTC
* gnu/packages/fonts.scm (font-overpass): New variable.
---
 gnu/packages/fonts.scm | 29 +++++++++++++++++++++++++++++
 1 file changed, 29 insertions(+)


base-commit: 20ab92719e24b4286aeee715cd9bd07315708a82

Comments

Nicolas Goaziou June 18, 2021, 10:16 a.m. UTC | #1
Hello,

Sarah Morgensen via Guix-patches via <guix-patches@gnu.org> writes:

> * gnu/packages/fonts.scm (font-overpass): New variable.

Thank you. I added a copyright line for you at the top of the file and
applied your patch.

Please note that adding new packages at the end of files is likely to
introduce merge conflicts. I suggest to choose an alphabetic or a random
location instead.

Regards,
diff mbox series

Patch

diff --git a/gnu/packages/fonts.scm b/gnu/packages/fonts.scm
index fe4d3efb5e..16132848d7 100644
--- a/gnu/packages/fonts.scm
+++ b/gnu/packages/fonts.scm
@@ -2176,3 +2176,32 @@  neighborhood of Buenos Aires inspired Julieta Ulanovsky to design this
 typeface and rescue the beauty of urban typography that emerged in the first
 half of the twentieth century.")
     (license license:silofl1.1)))
+
+(define-public font-overpass
+  (package
+    (name "font-overpass")
+    (version "3.0.4")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/RedHatOfficial/Overpass")
+             (commit version)))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "1pl7zpwlx0j2xv23ahnpmbb4a5d6ib2cjck5mxqzi3jjk25rk9kb"))))
+    (build-system font-build-system)
+    (arguments
+     `(#:phases
+       (modify-phases %standard-phases
+         (add-after 'unpack 'delete-webfonts
+           (lambda _
+             (delete-file-recursively "webfonts"))))))
+    (home-page "https://overpassfont.org")
+    (synopsis "Sans serif font family inspired by Highway Gothic")
+    (description
+     "Overpass is a sans-serif typeface based on the U.S. interstate highway
+road signage typefaces, adapted for on-screen display and user interfaces.
+Overpass includes proprotional and monospace variants.")
+    (license (list license:silofl1.1
+                   license:lgpl2.1))))