diff mbox series

[bug#64867,v2] gnu: inkscape: Update to 1.2.2

Message ID 26b7015b7e56c467f8f313d0179e1872f37a9810.1690435249.git.atai@atai.org
State New
Headers show
Series [bug#64867,v2] gnu: inkscape: Update to 1.2.2 | expand

Commit Message

Andy Tai July 27, 2023, 5:21 a.m. UTC
* gnu/packages/inkscape.scm (inkscape): Update to 1.2.2
---
 gnu/packages/inkscape.scm | 14 +++++++++++---
 1 file changed, 11 insertions(+), 3 deletions(-)


base-commit: c7e45139faa27b60f2c7d0a4bc140f9793d97d47

Comments

Maxim Cournoyer Sept. 5, 2023, 3:06 p.m. UTC | #1
Hello,

Andy Tai <atai@atai.org> writes:

> * gnu/packages/inkscape.scm (inkscape): Update to 1.2.2

You forgot to mention the actual (other) changes.  readline was added;
is this intentional?  The changelog helps ensuring it is.

> ---
>  gnu/packages/inkscape.scm | 14 +++++++++++---
>  1 file changed, 11 insertions(+), 3 deletions(-)
>
> diff --git a/gnu/packages/inkscape.scm b/gnu/packages/inkscape.scm
> index aa2c6419a0..6b6ffb2738 100644
> --- a/gnu/packages/inkscape.scm
> +++ b/gnu/packages/inkscape.scm
> @@ -50,6 +50,7 @@ (define-module (gnu packages inkscape)
>    #:use-module (gnu packages python)
>    #:use-module (gnu packages python-web)
>    #:use-module (gnu packages python-xyz)
> +  #:use-module (gnu packages readline)
>    #:use-module (gnu packages xml)
>    #:use-module (gnu packages ghostscript)
>    #:use-module (gnu packages fontutils)
> @@ -286,7 +287,7 @@ (define-public inkscape
>    (package
>      (inherit inkscape/stable)
>      (name "inkscape")
> -    (version "1.2.1")
> +    (version "1.2.2")
>      (source
>       (origin
>         (inherit (package-source inkscape/stable))
> @@ -294,13 +295,18 @@ (define-public inkscape
>         (uri (string-append "https://media.inkscape.org/dl/"
>                             "resources/file/"
>                             "inkscape-" version ".tar.xz"))
> +       (patches (list ))

I'd use '() (and perhaps a comment).

>         (sha256
> -        (base32 "06scilds4p4bw337ss22nfdxy2kynv5yjw6vq6nlpjm7xfh7vkj6"))))
> +        (base32 "1i55x0zbmwgvcl8fai9m3zy7rpc0rwfk1vs8wqsib8n00c6zvix0"))))
>      (build-system cmake-build-system)
>      (arguments
>       (substitute-keyword-arguments (package-arguments inkscape/stable)
>         ((#:phases phases)
>          `(modify-phases ,phases
> +           (add-after 'unpack  'fix-unaliased-2geom-reference
> +              (lambda _
> +                  (substitute* (find-files "." "CMakeLists.txt")
> +                  	  (("2Geom::2geom") "2geom"))))

I'm a bit surprised by this change; did upstream update their way to
detect 2geom?  Perhaps we could stop unbundling it ourselves.

>             (replace 'wrap-program
>               ;; Ensure Python is available at runtime.
>               (lambda* (#:key outputs #:allow-other-keys)
> @@ -313,5 +319,7 @@ (define-public inkscape
>                     `("GDK_PIXBUF_MODULE_FILE" =
>                       (,(getenv "GDK_PIXBUF_MODULE_FILE")))))))))))
>      (inputs (modify-inputs (package-inputs inkscape/stable)
> -              (append python-cssselect)))        ;to render qrcode
> +              (append gspell lib2geom
> +               python-cssselect  ;to render qrcode
> +               readline)))

One package per line would be more readable here.
                 (append package1
                         package2
                         ...)
Maxim Cournoyer Jan. 24, 2024, 2:58 p.m. UTC | #2
Hello,

Maxim Cournoyer <maxim.cournoyer@gmail.com> writes:

> Hello,
>
> Andy Tai <atai@atai.org> writes:
>
>> * gnu/packages/inkscape.scm (inkscape): Update to 1.2.2
>
> You forgot to mention the actual (other) changes.  readline was added;
> is this intentional?  The changelog helps ensuring it is.

Gentle ping!
Andy Tai Jan. 24, 2024, 3:37 p.m. UTC | #3
OK I will update

On Wed, Jan 24, 2024 at 6:58 AM Maxim Cournoyer <maxim.cournoyer@gmail.com>
wrote:

> Hello,
>
> Maxim Cournoyer <maxim.cournoyer@gmail.com> writes:
>
> > Hello,
> >
> > Andy Tai <atai@atai.org> writes:
> >
> >> * gnu/packages/inkscape.scm (inkscape): Update to 1.2.2
> >
> > You forgot to mention the actual (other) changes.  readline was added;
> > is this intentional?  The changelog helps ensuring it is.
>
> Gentle ping!
>
> --
> Thanks,
> Maxim
>
Maxim Cournoyer March 9, 2024, 6:34 p.m. UTC | #4
Hi,

Andy Tai <atai@atai.org> writes:

> OK I will update
>
> On Wed, Jan 24, 2024 at 6:58 AM Maxim Cournoyer <maxim.cournoyer@gmail.com>
> wrote:
>
>> Hello,
>>
>> Maxim Cournoyer <maxim.cournoyer@gmail.com> writes:
>>
>> > Hello,
>> >
>> > Andy Tai <atai@atai.org> writes:
>> >
>> >> * gnu/packages/inkscape.scm (inkscape): Update to 1.2.2
>> >
>> > You forgot to mention the actual (other) changes.  readline was added;
>> > is this intentional?  The changelog helps ensuring it is.

Inkscape has since been updated to 1.3.2 on core-updates.

Closing!
diff mbox series

Patch

diff --git a/gnu/packages/inkscape.scm b/gnu/packages/inkscape.scm
index aa2c6419a0..6b6ffb2738 100644
--- a/gnu/packages/inkscape.scm
+++ b/gnu/packages/inkscape.scm
@@ -50,6 +50,7 @@  (define-module (gnu packages inkscape)
   #:use-module (gnu packages python)
   #:use-module (gnu packages python-web)
   #:use-module (gnu packages python-xyz)
+  #:use-module (gnu packages readline)
   #:use-module (gnu packages xml)
   #:use-module (gnu packages ghostscript)
   #:use-module (gnu packages fontutils)
@@ -286,7 +287,7 @@  (define-public inkscape
   (package
     (inherit inkscape/stable)
     (name "inkscape")
-    (version "1.2.1")
+    (version "1.2.2")
     (source
      (origin
        (inherit (package-source inkscape/stable))
@@ -294,13 +295,18 @@  (define-public inkscape
        (uri (string-append "https://media.inkscape.org/dl/"
                            "resources/file/"
                            "inkscape-" version ".tar.xz"))
+       (patches (list ))
        (sha256
-        (base32 "06scilds4p4bw337ss22nfdxy2kynv5yjw6vq6nlpjm7xfh7vkj6"))))
+        (base32 "1i55x0zbmwgvcl8fai9m3zy7rpc0rwfk1vs8wqsib8n00c6zvix0"))))
     (build-system cmake-build-system)
     (arguments
      (substitute-keyword-arguments (package-arguments inkscape/stable)
        ((#:phases phases)
         `(modify-phases ,phases
+           (add-after 'unpack  'fix-unaliased-2geom-reference
+              (lambda _
+                  (substitute* (find-files "." "CMakeLists.txt")
+                  	  (("2Geom::2geom") "2geom"))))
            (replace 'wrap-program
              ;; Ensure Python is available at runtime.
              (lambda* (#:key outputs #:allow-other-keys)
@@ -313,5 +319,7 @@  (define-public inkscape
                    `("GDK_PIXBUF_MODULE_FILE" =
                      (,(getenv "GDK_PIXBUF_MODULE_FILE")))))))))))
     (inputs (modify-inputs (package-inputs inkscape/stable)
-              (append python-cssselect)))        ;to render qrcode
+              (append gspell lib2geom
+               python-cssselect  ;to render qrcode
+               readline)))
     (properties (alist-delete 'hidden? (package-properties inkscape/stable)))))