diff mbox series

[bug#70693] gnu: nss/fixed: Tweak performance test.

Message ID 26a7162056587eb3c5855e6d35e70c15b9fb72cc.1714556505.git.mail@cbaines.net
State New
Headers show
Series [bug#70693] gnu: nss/fixed: Tweak performance test. | expand

Commit Message

Christopher Baines May 1, 2024, 9:41 a.m. UTC
As I'm seeing this test fail with results of 5 to 7 seconds.

* gnu/packages/nss.scm (nss/fixed)[arguments]: Tweak a test to have a higher
time threshold.

Change-Id: Icb0551cd986acf67b2ba17dc8772a67b9747d31a
---
 gnu/packages/nss.scm | 8 ++++++++
 1 file changed, 8 insertions(+)


base-commit: 7d4ae2fca723114fb1df56de33b82177fbc4d0a6
diff mbox series

Patch

diff --git a/gnu/packages/nss.scm b/gnu/packages/nss.scm
index 162e748094..60bc4d52de 100644
--- a/gnu/packages/nss.scm
+++ b/gnu/packages/nss.scm
@@ -280,6 +280,14 @@  (define-public nss/fixed
                          (setenv "USE_IP" "TRUE")
                          (setenv "IP_ADDRESS" "127.0.0.1")
 
+                         ;; This specific test is looking at performance "now
+                         ;; verify that we can quickly dump a database", and
+                         ;; we're not testing performance here (especially
+                         ;; since we're using faketime), so raise the
+                         ;; threshold
+                         (substitute* "tests/dbtests/dbtests.sh"
+                           ((" -lt 5") " -lt 50"))
+
                          ;; The "PayPalEE.cert" certificate expires every six months,
                          ;; leading to test failures:
                          ;; <https://bugzilla.mozilla.org/show_bug.cgi?id=609734>.  To