diff mbox series

[bug#37718] Add gnome-mahjongg.

Message ID 269fdb5f-7d0e-4f2f-947d-eea43515c5df@www.fastmail.com
State Accepted
Headers show
Series [bug#37718] Add gnome-mahjongg. | expand

Commit Message

David Wilson Oct. 12, 2019, 4:17 p.m. UTC
Hi fellow Guixers,

Here's a patch to add the (highly addictive) game Gnome Mahjongg.  Please let me know if there's any way this package definition can be improved!

Happy hacking,

David
diff mbox series

Patch

From a589ef5124d265b9c0fb646b35e8efe852b74855 Mon Sep 17 00:00:00 2001
From: David Wilson <david@daviwil.com>
Date: Sat, 12 Oct 2019 09:07:11 -0700
Subject: [PATCH] gnu: Add gnome-mahjongg.

* gnu/packages/gnome.scm (gnome-mahjongg) New variable.
---
 gnu/packages/gnome.scm | 37 +++++++++++++++++++++++++++++++++++++
 1 file changed, 37 insertions(+)

diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 91a781bfba..ce58ff4006 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -41,6 +41,7 @@ 
 ;;; Copyright © 2019 Jonathan Frederickson <jonathan@terracrypt.net>
 ;;; Copyright © 2019 Maxim Cournoyer <maxim.cournoyer@gmail.com>
 ;;; Copyright © 2019 Martin Becze <mjbecze@riseup.net>
+;;; Copyright © 2019 David Wilson <david@daviwil.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -8394,3 +8395,39 @@  access library.  It only implements the core plumbing functions, not really the
 higher level porcelain stuff.")
     (home-page "https://wiki.gnome.org/Projects/Libgit2-glib")
     (license license:gpl2+)))
+
+(define-public gnome-mahjongg
+  (package
+    (name "gnome-mahjongg")
+    (version "3.35.1")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://gitlab.gnome.org/GNOME/gnome-mahjongg.git")
+                    (commit version)))
+              (sha256
+               (base32
+                "019a66a4m5w4kkb0sm6gxj0wi54n06zdxdlmyqw7h8kbakjizv7l"))))
+    (build-system meson-build-system)
+    (arguments
+     `(#:glib-or-gtk? #t))
+    (native-inputs
+     `(("appstream-glib" ,appstream-glib)
+       ("gettext" ,gettext-minimal)
+       ("glib:bin" ,glib "bin") ;; For glib-compile-resources
+       ("gtk+" ,gtk+ "bin")     ;; For gtk-update-icon-cache
+       ("itstool" ,itstool)
+       ("pkg-config" ,pkg-config)
+       ("vala" ,vala)))
+    (propagated-inputs
+     `(("dconf" ,dconf)))
+    (inputs
+     `(("glib" ,glib)
+       ("gtk+" ,gtk+)
+       ("librsvg" ,librsvg)))
+    (synopsis "Mahjongg tile-matching game")
+    (description "Gnome Mahjongg is a game based on the classic Chinese tile-
+matching game Mahjong.  It features multiple board layouts, tile themes, and a
+high score table.")
+    (home-page "https://wiki.gnome.org/Apps/Mahjongg")
+    (license license:gpl2)))
-- 
2.23.0