diff mbox series

[bug#45153] gnu: rottlog: Fix mail reporting.

Message ID 2691c330f7615c298baeb859c35f489f0de30467.camel@free.fr
State Accepted
Headers show
Series [bug#45153] gnu: rottlog: Fix mail reporting. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

dftxbs3e Dec. 10, 2020, 3:41 a.m. UTC
Hello!

I was getting errors like this in my GNU Guix System installation:

# cat /var/log/mcron.log
/gnu/store/8q2i735qhdivn5pn87b6ay7z16xnf6py-rottlog-
0.72.2/sbin/rottlog: line 1596: sendmail: command not found
/gnu/store/8q2i735qhdivn5pn87b6ay7z16xnf6py-rottlog-
0.72.2/sbin/rottlog: line 1596: sendmail: command not found
/gnu/store/8q2i735qhdivn5pn87b6ay7z16xnf6py-rottlog-
0.72.2/sbin/rottlog: line 1596: sendmail: command not found
/gnu/store/8q2i735qhdivn5pn87b6ay7z16xnf6py-rottlog-
0.72.2/sbin/rottlog: line 1596: sendmail: command not found
/gnu/store/8q2i735qhdivn5pn87b6ay7z16xnf6py-rottlog-
0.72.2/sbin/rottlog: line 1596: sendmail: command not found

I am guessing this means sendmail needs to be added as propagated-
inputs to ensure it is available to rottlog at runtime.

Attached patch with these changes!

Thank you!

Comments

Ludovic Courtès Dec. 11, 2020, 5:57 p.m. UTC | #1
Hi,

dftxbs3e <dftxbs3e@free.fr> skribis:

> From 6aab4645706f9fe285c253142efe4e9fd40f2c3a Mon Sep 17 00:00:00 2001
> From: =?UTF-8?q?L=C3=A9o=20Le=20Bouter?= <lle-bout@zaclys.net>
> Date: Thu, 10 Dec 2020 04:35:38 +0100
> Subject: [PATCH] gnu: rottlog: Fix mail reporting.
>
> * gnu/packages/admin.scm (rottlog):
> [propagated-inputs]: Add sendmail.
> ---
>  gnu/packages/admin.scm | 1 +
>  1 file changed, 1 insertion(+)
>
> diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
> index 9df14b5ca0..5c22d40d1d 100644
> --- a/gnu/packages/admin.scm
> +++ b/gnu/packages/admin.scm
> @@ -1385,6 +1385,7 @@ at once based on a Perl regular expression.")
>                       ("automake" ,automake)
>                       ("util-linux" ,util-linux))) ; for 'cal'
>      (inputs `(("coreutils*" ,coreutils)))
> +    (propagated-inputs `(("sendmail" ,sendmail)))

A better approach would be to avoid the propagated inputs and instead
replace the reference to ‘mail’ (or ‘sendmail’?) in the code by a
reference to its absolute file name (if it’s ‘mail’, I’d suggest picking
the ‘mail’ command from Inetutils.)

Thanks,
Ludo’.
diff mbox series

Patch

From 6aab4645706f9fe285c253142efe4e9fd40f2c3a Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?L=C3=A9o=20Le=20Bouter?= <lle-bout@zaclys.net>
Date: Thu, 10 Dec 2020 04:35:38 +0100
Subject: [PATCH] gnu: rottlog: Fix mail reporting.

* gnu/packages/admin.scm (rottlog):
[propagated-inputs]: Add sendmail.
---
 gnu/packages/admin.scm | 1 +
 1 file changed, 1 insertion(+)

diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index 9df14b5ca0..5c22d40d1d 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -1385,6 +1385,7 @@  at once based on a Perl regular expression.")
                      ("automake" ,automake)
                      ("util-linux" ,util-linux))) ; for 'cal'
     (inputs `(("coreutils*" ,coreutils)))
+    (propagated-inputs `(("sendmail" ,sendmail)))
     (home-page "https://www.gnu.org/software/rottlog/")
     (synopsis "Log rotation and management")
     (description
-- 
2.29.2