diff mbox series

[bug#51046,v2] gnu: Add rdate.

Message ID 268a9188fbcd506422f8d606045d133d89e27db6.1709840586.git.juli@incana.org
State New
Headers show
Series [bug#51046,v2] gnu: Add rdate. | expand

Commit Message

Juliana Sims March 7, 2024, 7:43 p.m. UTC
Hello!

It's been quite some time since this patch was submitted, and it still works!
It needed two small changes -- adding the autotools module and using a different
license symbol format -- so I've gone ahead and made those changes. I also took
the liberty of updating the inputs to the new format. There are no semantic
changes to the patch itself.

Thanks again for submitting this!
Juli

* gnu/packages/time.scm (rdate): New variable.

Change-Id: I12217c62fe17a93bdb5364f807804eea7fc57a23
---
 gnu/packages/time.scm | 25 +++++++++++++++++++++++++
 1 file changed, 25 insertions(+)


base-commit: 7f2f1bcddae64c48f793cde15c21617fa706c157
diff mbox series

Patch

diff --git a/gnu/packages/time.scm b/gnu/packages/time.scm
index b0d800da949..14b02352d6f 100644
--- a/gnu/packages/time.scm
+++ b/gnu/packages/time.scm
@@ -40,6 +40,7 @@ 
 ;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.
 
 (define-module (gnu packages time)
+  #:use-module (gnu packages autotools)
   #:use-module (gnu packages base)
   #:use-module (gnu packages check)
   #:use-module (gnu packages compression)
@@ -549,6 +550,30 @@  (define-public python-aniso8601
      "This package contains a library for parsing ISO 8601 datetime strings.")
     (license bsd-3)))
 
+(define-public rdate
+  (let ((commit "91d84610e3695e90a884e2953908e95a856a9b74")
+        (revision "1"))
+    (package
+      (name "rdate")
+      (version (git-version "1.4" revision commit))
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+               (url "https://github.com/njh/rdate")
+               (commit commit)))
+         (file-name (git-file-name name version))
+         (sha256
+          (base32 "002ryjq8gj1ml5la4v6dr3bh1zw5kxwy65rpziq8d2ccccarhv59"))))
+      (build-system gnu-build-system)
+      (native-inputs (list autoconf automake))
+      (synopsis "Get date and time based on RFC 868")
+      (description
+       "@code{rdate} connects to an RFC 868 time server over a TCP/IP network,
+printing the returned time and/or setting the system clock.")
+      (home-page "https://www.aelius.com/njh/rdate/")
+      (license gpl2))))
+
 (define-public datefudge
   (package
     (name "datefudge")