diff mbox series

[bug#69268,2/2] gnu: Add python-heatwave.

Message ID 25eca894b682613e3dcb9eda707547e7c73bc3d1.1708336084.git.w@wmeyer.eu
State New
Headers show
Series Add python-heatwave. | expand

Commit Message

Wilko Meyer Feb. 19, 2024, 9:53 a.m. UTC
* gnu/packages/python-xyz.scm (python-heatwave): New variable.
* gnu/packages/python-xyz.scm: Add my copyright header.

Change-Id: I640aecb3a0d9c454333a3913c039c637d24d9f79
---
 gnu/packages/python-xyz.scm | 19 +++++++++++++++++++
 1 file changed, 19 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index c8fc5e1f7c..e318438c94 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -147,6 +147,7 @@ 
 ;;; Copyright © 2023 Attila Lendvai <attila@lendvai.name>
 ;;; Copyright © 2023, 2024 Troy Figiel <troy@troyfigiel.com>
 ;;; Copyright © 2024 Timothee Mathieu <timothee.mathieu@inria.fr>
+;;; Copyright © 2024 Wilko Meyer <w@wmeyer.eu>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -31533,6 +31534,24 @@  (define-public python-roundrobin
 distribution in Python.")
     (license license:expat)))
 
+(define-public python-heatwave
+  (package
+    (name "python-heatwave")
+    (version "1.2.1")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "heatwave" version))
+       (sha256
+        (base32 "1zzwmb9hvbyswzjgap02rrq8p44hb6xlzk1wd8w01mh2vva0xlx7"))))
+    (build-system pyproject-build-system)
+    (propagated-inputs (list python-click python-gitpython python-monthdelta))
+    (home-page "https://github.com/james-stoup/heatwave")
+    (synopsis "A way of visualizing a heat map of a git repo")
+    (description
+     "This package provides a way of visualizing a heat map of a git repo.")
+    (license license:gpl3)))
+
 (define-public python-helpdev
   (package
     (name "python-helpdev")