diff mbox series

[bug#64387,6/6] gnu: Remove arcan-wayland.

Message ID 25d18f87d518a85e6f62050e2f58f322b3827265.1688161433.git.a.r.draidi@redscript.org
State New
Headers show
Series Update and rework arcan | expand

Commit Message

Ahmad Draidi June 30, 2023, 10:07 p.m. UTC
This package has been merged into arcan in upstream.

* gnu/packages/arcan.scm (arcan-wayland): Remove variable.
---
 gnu/packages/arcan.scm | 32 --------------------------------
 1 file changed, 32 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/arcan.scm b/gnu/packages/arcan.scm
index 05d2f58fc2..53a1f75411 100644
--- a/gnu/packages/arcan.scm
+++ b/gnu/packages/arcan.scm
@@ -235,35 +235,3 @@  (define-public xarcan
  to map Xlib/Xcb/X clients to a running arcan instance.  It allows running an X session
 as a window under Arcan.")
       (license license:expat))))
-
-(define-public arcan-wayland
-  (package
-    (inherit arcan)
-    (name "arcan-wayland")
-    (native-inputs
-     (list pkg-config))
-    (inputs
-     (list arcan
-           libseccomp
-           libxkbcommon
-           mesa
-           wayland
-           wayland-protocols))
-    (arguments
-     `(#:tests? #f
-       #:phases
-       (modify-phases %standard-phases
-         (add-before 'configure 'chdir
-           (lambda _
-             (chdir "src/tools/waybridge")
-             #t))
-         (add-after 'unpack 'fix-cmake-find-shmif
-           (lambda* (#:key inputs #:allow-other-keys)
-             (substitute* "src/platform/cmake/modules/Findarcan_shmif.cmake"
-               (("/usr/local") (assoc-ref inputs "arcan")))
-             #t)))))
-    (synopsis "Wayland protocol service for Arcan")
-    (description "Arcan-wayland (waybridge) bridges Wayland connections
-with an Arcan connection point.  It allows Wayland compatible clients
-to connect and render using Arcan.")
-    (license license:bsd-3)))