diff mbox series

[bug#66208,v2,1/1] gnu: Add python-shshsh.

Message ID 25cb61e035b1b9adb0395f6f5f8a80a0d5e031f0.1712266786.git.steve@futurile.net
State New
Headers show
Series Review python-shshsh | expand

Commit Message

Steve George April 4, 2024, 9:46 p.m. UTC
From: Andrew Jose <arnav.jose@gmail.com>

* gnu/packages/python-xyz.scm (python-shshsh): New variable.

Reviewed-by: Steve George <steve@futurile.net>
Change-Id: Iadd75c769a4391195b32789590f94fd8afbe21b6
---
 gnu/packages/python-xyz.scm | 29 +++++++++++++++++++++++++++++
 1 file changed, 29 insertions(+)

Comments

Christopher Baines April 7, 2024, 7:31 p.m. UTC | #1
Steve George <steve@futurile.net> writes:

> From: Andrew Jose <arnav.jose@gmail.com>
>
> * gnu/packages/python-xyz.scm (python-shshsh): New variable.
>
> Reviewed-by: Steve George <steve@futurile.net>
> Change-Id: Iadd75c769a4391195b32789590f94fd8afbe21b6
> ---
>  gnu/packages/python-xyz.scm | 29 +++++++++++++++++++++++++++++
>  1 file changed, 29 insertions(+)

Thanks both, I tweaked the indentation and pushed this to master as
1977fa35c553f4ba9427876f065f5816f7b70b5b.

Chris
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index cd10f304c83..f201b3ec31e 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -20738,6 +20738,35 @@  (define-public python-shellingham
 running in.")
     (license license:isc)))
 
+(define-public python-shshsh
+  (package
+   (name "python-shshsh")
+   (version "1.0.5")
+   (source
+    (origin
+     (method git-fetch)
+     (uri
+       (git-reference
+         (url "https://github.com/zqqqqz2000/shshsh")
+         (commit
+           "fd21c8696aebaae04507760c16cb45979291fef5")))
+       (file-name (git-file-name name version))
+       (sha256
+         (base32
+           "1wzqyj1a6jj6cyv5ymzy834qm2lyq80yy1kfz0q0zayq9gm1cj7f"))))
+   (build-system pyproject-build-system)
+   (native-inputs
+     (list python-poetry-core
+           python-pytest
+           python-tox))
+   (home-page "https://github.com/zqqqqz2000/shshsh")
+   (synopsis "Write Shell commands simply and safely within Python")
+   (description "This package provides a way to write Shell commands from
+within Python.  Python functions can be chained together to process input
+Bash control characters are escapted so that parameters can be passed
+without worrying about command injection.")
+   (license license:expat)))
+
 (define-public python-memcached
   (package
     (name "python-memcached")