diff mbox series

[bug#73887] gnu: stklos: Update to 2.10.

Message ID 25a792faf44145f67bb76b8d11017221df1fc4fc.1729352925.git.ashish.is@lostca.se
State New
Headers show
Series [bug#73887] gnu: stklos: Update to 2.10. | expand

Commit Message

Ashish SHUKLA Oct. 19, 2024, 3:48 p.m. UTC
* gnu/packages/scheme.scm (stklos): Update to 2.10.
  [inputs]: Add variable. [native-inputs]: Add variable.
  [arguments] Add configure-flags.

Change-Id: Ife374dd60ef17129fa88b7a0940ab914e7b3c396
---
Hi,

Attached patch updates STklos to 2.10. For readline/libedit support, it
relies on rtld, this is accomplished by linking it with readline, so it
gets added to the rpath, and therefore available at runtime.

Thanks!

 gnu/packages/scheme.scm | 11 +++++++++--
 1 file changed, 9 insertions(+), 2 deletions(-)


base-commit: 5794926bed6fad4598bb565fb7f49be4205b11a1

Comments

Z572 Oct. 19, 2024, 4:27 p.m. UTC | #1
Ashish SHUKLA via Guix-patches via <guix-patches@gnu.org> writes:

> * gnu/packages/scheme.scm (stklos): Update to 2.10.
>   [inputs]: Add variable. [native-inputs]: Add variable.
>   [arguments] Add configure-flags.

[inputs]: Add gmp, libgc, pcre2, libffi and readline.
[native-inputs]: Add pkg-config.
[arguments]<#:configure-flags>: set LDFLAGS flag.

>
> Change-Id: Ife374dd60ef17129fa88b7a0940ab914e7b3c396
> ---
> Hi,
>
> Attached patch updates STklos to 2.10. For readline/libedit support, it
> relies on rtld, this is accomplished by linking it with readline, so it
> gets added to the rpath, and therefore available at runtime.
>
> Thanks!
>
>  gnu/packages/scheme.scm | 11 +++++++++--
>  1 file changed, 9 insertions(+), 2 deletions(-)
>
> diff --git a/gnu/packages/scheme.scm b/gnu/packages/scheme.scm
> index 6f9d00e440..c97fab8b93 100644
> --- a/gnu/packages/scheme.scm
> +++ b/gnu/packages/scheme.scm
> @@ -86,6 +86,7 @@ (define-module (gnu packages scheme)
>    #:use-module (gnu packages netpbm)
>    #:use-module (gnu packages pcre)
>    #:use-module (gnu packages pkg-config)
> +  #:use-module (gnu packages readline)
>    #:use-module (gnu packages sqlite)
>    #:use-module (gnu packages tex)
>    #:use-module (gnu packages texinfo)
> @@ -1275,7 +1276,7 @@ (define-public emacs-gerbil-mode
>  (define-public stklos
>    (package
>      (name "stklos")
> -    (version "1.70")
> +    (version "2.10")
>      (source (origin
>                (method url-fetch)
>                ;; TODO: Unbundle pcre, libgc, and libffi.
> @@ -1283,12 +1284,18 @@ (define-public stklos
>                                    version ".tar.gz"))
>                (sha256
>                 (base32
> -                "1iw3pgycjz3kz3jd1855v2ngf8ib2almpf8v058n1mkj1qd2b88m"))))
> +                "0hd05r5pr3yhgq44n5sqdmvkpgnhf5fybmis2g3gwj10z52h7gvd"))))
>      (build-system gnu-build-system)
> +    (native-inputs (list pkg-config))
> +    (inputs (list gmp libgc pcre2 libffi readline))
>      (arguments
>       (list
>        #:modules `((ice-9 ftw)
>                    ,@%default-gnu-modules)
> +      #:configure-flags
> +      '(list (string-append "LDFLAGS=-L"
> +               (assoc-ref %build-inputs "readline")
> +               "/lib -lreadline"))

i think should

#:configure-flags
  #~(list (string-append "LDFLAGS=-L" #$(this-package-input "readline")
          "/lib -lreadline"))

>        #:phases
>        #~(modify-phases %standard-phases
>            (add-before 'configure 'patch-sh-references
>
> base-commit: 5794926bed6fad4598bb565fb7f49be4205b11a1
diff mbox series

Patch

diff --git a/gnu/packages/scheme.scm b/gnu/packages/scheme.scm
index 6f9d00e440..c97fab8b93 100644
--- a/gnu/packages/scheme.scm
+++ b/gnu/packages/scheme.scm
@@ -86,6 +86,7 @@  (define-module (gnu packages scheme)
   #:use-module (gnu packages netpbm)
   #:use-module (gnu packages pcre)
   #:use-module (gnu packages pkg-config)
+  #:use-module (gnu packages readline)
   #:use-module (gnu packages sqlite)
   #:use-module (gnu packages tex)
   #:use-module (gnu packages texinfo)
@@ -1275,7 +1276,7 @@  (define-public emacs-gerbil-mode
 (define-public stklos
   (package
     (name "stklos")
-    (version "1.70")
+    (version "2.10")
     (source (origin
               (method url-fetch)
               ;; TODO: Unbundle pcre, libgc, and libffi.
@@ -1283,12 +1284,18 @@  (define-public stklos
                                   version ".tar.gz"))
               (sha256
                (base32
-                "1iw3pgycjz3kz3jd1855v2ngf8ib2almpf8v058n1mkj1qd2b88m"))))
+                "0hd05r5pr3yhgq44n5sqdmvkpgnhf5fybmis2g3gwj10z52h7gvd"))))
     (build-system gnu-build-system)
+    (native-inputs (list pkg-config))
+    (inputs (list gmp libgc pcre2 libffi readline))
     (arguments
      (list
       #:modules `((ice-9 ftw)
                   ,@%default-gnu-modules)
+      #:configure-flags
+      '(list (string-append "LDFLAGS=-L"
+               (assoc-ref %build-inputs "readline")
+               "/lib -lreadline"))
       #:phases
       #~(modify-phases %standard-phases
           (add-before 'configure 'patch-sh-references